Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Relationship field in grid field in translation not saving

Status Resolved
Add-on / Version Publisher 3.5.0
Severity
EE Version 6.0.6

Hop Studios

Nov 18, 2021

A client reported that the relationship field is not saving in the grid columns in non-default language copies.

Are there any other similar reports? It’s a rather simple site.

#1

BoldMinded (Brian)

Nov 18, 2021

Nothing comes to mind but from the 3.5 change log: Relationship fields may not have correctly displayed translated content

You’ll need to provide more details, screenshots, videos etc. Is it truly not saving, or is it just not displaying the correct values on the front-end? Have you tried to replicate it in a simpler scenario?

#2

Hop Studios

Nov 18, 2021

I can try this on a new installation but currently what’s happening is:
On the entry edit screen: the row that should have the selected Bio from a relationship field is blank (i.e. shows the Relate Entry button) after multiple attempts to save it in German
If I do SELECT * FROM exp_publisher_relationships WHERE parent_id = 35 I do see both draft/open rows with correct parent_id and child_id and publisher_lang_id
In the frontend, the English copy shows its correct related entry title and the German one is just blank

#3

BoldMinded (Brian)

Nov 19, 2021

Is this a single relationship field or multiple? This is why I ask for screenshots and or videos so I can see exactly what you’re seeing and try to replicate it.

#4

BoldMinded (Brian)

Nov 19, 2021

Is this a new install or existing install that was recently upgraded? If upgraded what was the old version prior to the upgrade?

#5

BoldMinded (Brian)

Nov 19, 2021

I tried to replicate this based on the info provided but I can’t, so I’m going to need a video and more specific info before I can look into this further.

#6

Hop Studios

Nov 19, 2021

I duplicated the issues on a testing site and I’ve edited the ticket info to include the password.

Please let me know if you’d like to access the FTP also.

The site is upgraded from 5.4 to 6.1 and Publisher 3.3.1 to 3.5.0 just now. But the grid field is newly created after the upgrade.

#7

Hop Studios

Nov 19, 2021

Go to Blog and edit Blog 11. Choose Espanol and you’ll see 2 grid rows with the relationship field. Try relating an entry and save. They won’t stick for the Espanol copy. But the English copy is just fine.

#8

BoldMinded (Brian)

Nov 19, 2021

Thanks for creating the site but I’d still prefer the video, and template code used to recreate the issue. I only login to sites as a last resort.

#9

BoldMinded (Brian)

Nov 22, 2021

Can you provide FTP access so I can look at this closer? Its not how I prefer to work on things like this but I can’t replicate this locally.

#10

BoldMinded (Brian)

Nov 22, 2021

Ok, I upgraded my local environment from 6.1.5, where it worked and I couldn’t replicate it, to 6.1.6, and now it isn’t working and I can replicate it. (╯°□°)╯︵ ┻━┻

I’ll dig into this and post an update when I have one.

#11

Hop Studios

Nov 22, 2021

I was just about to create a separate FTP account. Do you still need it?

#12

BoldMinded (Brian)

Nov 22, 2021

Ok, this isn’t a bug. You have Persistent Grid turned off, and Persistent Relationships turned on. You’ll need to turn off Persistent Relationships for this to work since the Rel field is inside the Grid field. As soon as I disabled both locally, it works as intended.

If I were you I’d go with both of those settings on or both off. Since the Rel field is inside the Grid field, the Grid field setting kind of supersedes the Rel field setting.

#13

Hop Studios

Nov 22, 2021

Hmm.. in most cases we’d like the relationships to stay persistent across different languages.

I thought about it for a few minutes and I actually think it’d make more sense if the Grid field setting is to ignore the Rel field setting should a Rel field exist inside a grid field. If persistent is turned off, then row counts and any content including relationship fields should not be persistent throughout all translations. Just my two cents.

I’ll advise the client to see how we will adjust the editorial workflow to select relationships for all languages.

Thanks!

#14

BoldMinded (Brian)

Nov 22, 2021

I doubt I’m going to make any changes to how this works to be honest. If anything I’ll update the docs to make it more clear, but this is the functionality that has been in place for years, so I’m not going to switch it up.

Login to reply