Publisher is EE6 compatible, but it does not support the Fluid field.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Structure page urls issues

Status Resolved
Add-on / Version Publisher Domain Control 3.3.1
Severity
EE Version 5.4

Studioweb

Jul 15, 2021

Follow up of https://boldminded.com/support/ticket/2233

I’ve 3 domains setup in the domain control:
https://nl.domain.com -> dutch
https://en.domain.com -> english
https://pl.domain.com -> polish

After I change the structure page url and url_title for the dutch language and visit the correct url there’s a redirect taken place from https://nl.domain.com/[new_url_title] to http://[new_url_title] so the domain is stripped somehow.

Only the english URL is accessible and this one is also set in exp_structure.

#1

BoldMinded (Brian)

Jul 15, 2021

Can you please peep videos screenshots of your publisher domain control settings page? Thanks.

#2

Studioweb

Jul 15, 2021

Comment has been marked private.

#3

BoldMinded (Brian)

Jul 15, 2021

And this only happens on Structure based URLs? You’ve tested native template_group/template based URLs and those work fine?

#4

BoldMinded (Brian)

Jul 15, 2021

What version of PDC are you using?

#5

Studioweb

Jul 16, 2021

The {segment_4_category_id} does work but structure pages not.
PDC version 2.2.0

#6

BoldMinded (Brian)

Jul 16, 2021

I don’t know what segment_4_category_id is in this context, and you didn’t verify if a normal template_group/template based url works or not.

#7

BoldMinded (Brian)

Jul 16, 2021

Can you make a video of the entire scenario as you’re seeing it? And also a video of what happens when you use a normal template_group/template based url, not a structure url?

#8

Studioweb

Jul 16, 2021

Comment has been marked private.

#9

BoldMinded (Brian)

Jul 16, 2021

Thanks for the video, but it doesn’t tell me much. I didn’t see the redirect happening where it’s making the incorrect url, http://[page] instead of http://domain.com/[page]

Are you hiding the domain name in your browser? If so you should reveal it, and show the redirection issue happening as you described it. Based on your previous post it’s not clear how Publisher Domain Control is involved in the issue.

#10

Studioweb

Jul 16, 2021

Comment has been marked private.

#11

BoldMinded (Brian)

Jul 16, 2021

What are your settings for this page?

#12

Studioweb

Jul 16, 2021

The same as the screenshot. Only first checkbox selected.

#13

BoldMinded (Brian)

Jul 16, 2021

There must be something else going on with your site then, because I can’t replicate the issue, and when I went to https://www.podobrace.pl/kontakt/ it actually redirected me to http://localhost/kontakt. It looks like you’re running Nginx. I’d take a look at that configuration and your re-write rules. Since I can’t replicate it, you’ll need to setup a clean EE installation to replicate the issue, then I can look into it further if you can replicate it again and provide CP and FTP access to that new clean installation.

#14

Studioweb

5 days ago

Comment has been marked private.

#15

Studioweb

5 days ago

Comment has been marked private.

#16

BoldMinded (Brian)

5 days ago

Did you attempt to replicate this in a clean environment?

Every time Publisher performs a redirect it adds a “X-Publisher-Redirect” header, so you can look for that.

#17

BoldMinded (Brian)

5 days ago

Comment has been marked private.

#18

Studioweb

5 days ago

Comment has been marked private.

#19

BoldMinded (Brian)

5 days ago

Glad you were able to track it down 😊

Login to reply