Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Can’t get nesting to work right

Status Resolved
Add-on / Version Bloqs 4.5.1
Severity
EE Version 6.0.2

Aasun Eble

Feb 23, 2021

Hi there,

I have a blog field (Full Menu) with “Nestable” enabled.  I have 4 bloqs created:
1. Menu Section (this is set as “can only be root”, and I have “Can have children” switched on, and Exact Children set to 1).
2. Menu Section Items (set as “Can’t be root and must be a child of another bloq”, and Menu Section is set as the parent).
3. Photo Banner (set as “can only be root” and no children)
4. Two Photo Row (set as “can only be root” and no children)

I have no Bloq Groups created.

All four bloqs are added to my channel field and Nestable is enabled.

However, When I click the green “+” to add a bloq to the root, “Menu Section” is not selectable.  (Neither is “Menu Section Items”.  But, since this can only be a child to “Menu Section” I don’t expect it to be selectable unless I’m adding it as a child).

I’ve tried all kinds of different settings combining Can only be root, can be nested at any level for the Menu Section (root) bloq.. But, the only way I can make it selectable is if I turn off “Nestable” on the channel field type.  When I do that, though, the Menu Section Items (child only bloq) can be selected at root.

I’ve followed the docs, but there isn’t a lot of detail about root/non-root and “nestability”.

#1

BoldMinded (Brian)

Feb 23, 2021

Hey Aasun. The next comment is going to have a link to the new 4.6 build that should be released in the next week or so. I’m to a point where it doesn’t make sense to debug an old build b/c this new one has so many additions and changes. Try the new build, and see if it works then.

#2

BoldMinded (Brian)

Feb 23, 2021

Comment has been marked private.

#3

Aasun Eble

Feb 23, 2021

Ok.  Just downloaded and installed 4.6.  Still no difference.  Do I need to do anything and create a bloq group in order to manage this nesting?

#4

BoldMinded (Brian)

Feb 23, 2021

No you don’t need to make groups. Do you see any JS errors in the console? I’ll login and take a look tomorrow. This surprises me bc it’s working on multiple sites right now.

#5

BoldMinded (Brian)

Feb 24, 2021

The login you provided to the CP isn’t working.

#6

BoldMinded (Brian)

Feb 24, 2021

Try setting the Exact Children option to 0 (which is unlimited). I’m wondering if there is a bug with that setting.

#7

Aasun Eble

Feb 24, 2021

Sorry about that!  I updated the password. Should work now.

I tried changing the children option to 0.  But, that didn’t make a difference.

#8

BoldMinded (Brian)

Feb 24, 2021

I see the issue. It looks like the Menu Section was once set to be the child of another block, but you changed that, but the settings did not save correctly. I’ll try to have a new build to you soon.

#9

Aasun Eble

Feb 24, 2021

Ok. So, if I delete that Menu Section and just create another, it should work correctly?  (unless the new build will be today.. then I’ll wait for the new build).

#10

BoldMinded (Brian)

Feb 24, 2021

Comment has been marked private.

#11

Aasun Eble

Feb 24, 2021

That did it!  Great!  thanks for the quick turn-around!

#12

BoldMinded (Brian)

Feb 24, 2021

Login to reply