EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: First time install, trouble enabling static cache

Status Resolved
Add-on / Version Speedy 1.3.0
Severity
EE Version 5.3.2

Paul Larson

Nov 22, 2020

I gave my best effort to make sure I wasn’t missing something obvious.

From the docs, to enable static cacheing:

1) Create a new directory in your document root (where index.php is) named static.
* Done!

2) Make sure speedy_static_enabled is not disabled in your config.php file.
* Done

3) Add the following code to the top of your .htaccess file (or create one if it does not exist).
* Done

4) At minimum, your config.php file should have the following for static caching to work: ‘$config[‘speedy_driver’] = ‘static’;’
* Done


5) Complete the installation in the Speedy control panel page.
* NOT done

=======

I’m on a Plesk server, where Nginx proxies requests to Apache. The .htaccess is definitely used (in a proxy setup, I assume nginx directives are also used.

Here is the top of my config.php

https://www.dropbox.com/s/4bbkmxjbrovyd3c/Screen%20Shot%202020-11-22%20at%209.04.11%20AM.png?dl=0

(Is it colliding with the existing ‘$config[‘cache_driver’] = ‘file’;’ line?)

Here is the top of my .htaccess

https://www.dropbox.com/s/1gtac6o8xwxfxe3/Screen%20Shot%202020-11-22%20at%208.59.51%20AM.png?dl=0

Here are my Nginx directives, configured in Plesk (where they are supposed to go)

https://www.dropbox.com/s/ukznc9lb0negcwf/Screen%20Shot%202020-11-22%20at%209.00.32%20AM.png?dl=0

(there ARE a few directives above Speedy’s, which I’ve not yet removed.

=======

I can’t yet enable the Static driver in Speedy:

https://www.dropbox.com/s/231ge193ee9a3tt/Screen%20Shot%202020-11-22%20at%209.01.44%20AM.png?dl=0

https://www.dropbox.com/s/ipkqkkl9hxfg8zf/Screen%20Shot%202020-11-22%20at%209.02.01%20AM.png?dl=0

======

TL;DR Are there steps to enable static that I’m missing? I made httpdocs/static, added ‘$config[‘speedy_driver’] = ‘static’;’ to my config.php.

 

#1

BoldMinded (Brian)

Nov 22, 2020

Do you have $config[‘speedy_static_enabled’] = ‘yes’; in your config file?

#2

BoldMinded (Brian)

Nov 22, 2020

I changed this in the docs, saying “make sure it is not disabled” isn’t very clear 😊

#3

BoldMinded (Brian)

Dec 27, 2020

Closing this out b/c it’s been over a month with no response, so I assume the issue is resolved.

Login to reply