EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Publisher - NavEE Support: no additional set of fields visible

Status Resolved
Add-on / Version Publisher 2.0.0
Severity
EE Version 5.3.2

Burgi von Mengershausen

Aug 24, 2020

Publisher - NavEE Support 2.0.0 does not show additional set of fields added to the bottom of NavEE’s navigation node.

Steps to reproduce:
Installed a fresh copy of ExpressionEngine 5.3.2
Also installed:
NavEE 3.1.19
Publisher 3.1.5
Publisher - NavEE Support 2.0.0

Created 2 languages in Publisher.
Created a NavEE navigation with one node in it.

Navigation item does not show additional set of fields added to the bottom of NavEE’s navigation node as demonstrated in your docs image: https://boldminded.com/assets/images/uploads/publisher-navee-screenshot.png

#1

BoldMinded (Brian)

Aug 24, 2020

Can you check your exp_extensions table to make sure there are 8 rows in there with “Publisher_navee_ext” in the class column. You should see rows for each of these:

['hook'=>'core_boot', 'method'=>'core_boot'],
            ['hook'=>'navee_extra_form_sections', 'method'=>'navee_extra_form_sections'],
            ['hook'=>'navee_update_navigation_item', 'method'=>'navee_update_navigation_item'],
            ['hook'=>'navee_modify_nav', 'method'=>'navee_modify_nav'],
            ['hook'=>'navee_get_cache', 'method'=>'navee_get_cache'],
            ['hook'=>'navee_set_cache', 'method'=>'navee_set_cache'],
            ['hook'=>'navee_strip_link', 'method'=>'navee_strip_link'],
            ['hook'=>'navee_modify_crumb', 'method'=>'navee_modify_crumb']

This is a little puzzling because I haven’t had to update the NavEE support extension for nearly 2 years, and I know other people are using it.

#2

Burgi von Mengershausen

Aug 25, 2020

Yes all 8 rows with “Publisher_navee_ext” in the class column are present!
i have experienced this bug on a live site first but i have reproduced this bug in a fresh install of ExpressionEngine 3.5.3 (screenshots are in this ticket)
PHP is 7.3.10

#3

Burgi von Mengershausen

Aug 25, 2020

i meant a fresh install of ExpressionEngine 5.3.2 in my previous comment

#4

BoldMinded (Brian)

Aug 26, 2020

Sorry for the delay on this. It isn’t working b/c I don’t think the NavEE developer has added the updates I sent him… 2 years ago. There are missing hook calls in the NavEE codebase, until those are added the Publisher - NavEE Support extension will never work :(

You should reach out to their support. I gave them access to my Github repo that contains the changes they need to make. You won’t be able to see these files, but Michael Witwicki should. https://github.com/litzinger/navee

#5

Burgi von Mengershausen

Sep 14, 2020

Hi Brian, i did contact Michael Witwicki via their contact form immediately after your last comment. No one replied.

#6

BoldMinded (Brian)

Sep 16, 2020

Comment has been marked private.

Login to reply

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.