EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Cache not breaking on channel entry change.

Status Resolved
Add-on / Version Speedy 1.1.2
Severity
EE Version 5.3.2

Emmanuel Pacheco

Jun 18, 2020

Hello.

I had caching working on a dev site, breaking and all.  Today we moved it over to a live site but now the caching is not breaking.  I cleared the drivers, cleared the tags.  I’m not on my homepage, I’m testing on a page one level down.  In the template I have: {exp:speedy:fragment driver="file" ttl="0" tags="execeventshp"} at the beginning and {/exp:speedy:fragment} at the end of the template.  The channel I’m working with is “EXEC Training Homepage”, and it only has one entry.  Under Clear Caching Rules, for this channel, I only have Clear Item as “execeventshp” to match the tag I used in the template.  Refresh is toggled “Off” and Clear Items is empty.

What is happening:
If I clear the cache and visit the page I will see it rendered with all my current settings and a cache file will be created “local/executive-education/item”.
Once I make a change to a field in that entry and save the changes they are not showing up on the webpage.  It’s only displaying the previous cached page.

My config.php has the following:

// SPEEDY CACHING

Note: The only way to apply the new changes to the channel entry is to manually remove the cached file.

$config[‘speedy_static_path’] = ‘/home/ermdevnc/public_html/ysped’;
$config[‘speedy_driver’] = ‘static’;
$config[‘speedy_static_enabled’] = ‘yes’;

My .htaccess has the following:

######## SPEEDY CACHING

  RewriteEngine On
  RewriteCond %{REQUEST_URI} !^/system [NC]
  RewriteCond %{QUERY_STRING} !ACT|URL [NC]
  RewriteCond %{REQUEST_METHOD} !=POST [NC]
  RewriteCond $1 !\.(css|js|gif|jpe?g|png) [NC]
  RewriteCond %{DOCUMENT_ROOT}/ysped/default_site/static%{REQUEST_URI}/index\.php -f
  RewriteRule ^ /ysped/default_site/static%{REQUEST_URI}/index\.php [L,QSA]

######## END SPEEDY CACHING

I’m using a custom folder for the cache files.

Thank you.

 

#1

BoldMinded (Brian)

Jun 18, 2020

Hi, Emmanuel. Since this worked in your dev environment and not production, this indicates to me it’s a server issue and not necessarily an add-on issue. I would double check your permissions to make sure the php processes have permission to delete files from the server (it’ll try to delete the file to clear the cache when an entry is saved), or some other potential permissions issues.

#2

Emmanuel Pacheco

Jun 18, 2020

Hi,  The only change network wise that changed was the DNS and URLs, the server is actually still the same server and space we developed on.  What specifically should we be checking with PHP?  Are the permissions you mentioned for the custom folder we are using?

#3

Emmanuel Pacheco

Jun 18, 2020

Also the Filesystem Driver Stats doesn’t seem to be updating.  Currently is showing:

Filesystem Driver Stats
Hits
Number of keys that have been requested and found present.
N/A
Misses
Number of items that have been requested and not found.
N/A
Uptime
Time that the server is running.
N/A

I tried manually changing the permissions on the actual item file under “executive-events” to 777 but that didn’t have an effect either.  In fact, I changed the permission on all the files and folders to 777. That too didn’t have an effect.

Login to reply

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.