Be sure to checkout our newest add-on Speedy!

EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Draft Preview inserts the index template name into the URL - is this standard?

Status Resolved
Add-on / Version Publisher 3.1.2
Severity
EE Version 5.3

Werner Gusset

Feb 17, 2020

The preview template URL in the channel settings must not mention the index template. To preview an entry on a index template we need to enter “/templategroup/{url_title}”. If we would enter the index like “templategroup/index/{url_title}” EE would not show the preview template it would go to our 404. That’ seems ok this way.

But in Publisher the Draft preview always inserts “/index” in to the preview URL like https://www.domain.de/de/lp/index/it-trans-2020-en?publisher_status=draft&publisher_key=xxxxxxxxxx and therefor does not show the preview and will go to our 404 page. Do we copy this Publisher preview URL from the preview window into the browser and delete /index we then would see the draft preview. Or if we would enter the /index segment in the channels preview config we then could see the Draft preview. But EE preview would then give an error.

I am wondering if this is really the case in general for Publisher or is it because of some wrong configuration? Does Publisher in the case I describe ignore the channel setting for the preview template and inserts “/index” automatically without need?

#1

BoldMinded (Brian)

Feb 17, 2020

It sounds like it is working as intended and yes Publisher ignores the channel setting for the preview. Publisher’s preview was made long before EE’s so it works a little differently. In my opinion you should pick one type of preview to use, and not use both.

#2

BoldMinded (Brian)

Feb 17, 2020

I’m going to look into making the two work better together. I’ll post an update when I have a build to share.

#3

Werner Gusset

Feb 17, 2020

Thanks. Ignoring the index segment in the URL is standard in EE since I remember back to EE 1.3. Maybe pMachine did it already

#4

BoldMinded (Brian)

Feb 17, 2020

Werner, try the build in the next comment. I added a new setting to use EE’s Live Preview URL in the channel settings page instead of Publisher Draft Preview URL settings. New config option as seen here: https://d.pr/i/WdZzKL and a warning message on Publisher’s settings page indicating that the values are not used if the setting is turned on: https://d.pr/i/OlWHHd

#5

BoldMinded (Brian)

Feb 17, 2020

Comment has been marked private.

#6

Werner Gusset

Feb 17, 2020

Brian, thank you very much. This is a nice solution and it’s working.

#7

BoldMinded (Brian)

Feb 17, 2020

Awesome, good to hear!

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.