EE compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field.

ExpressionEngine.com licenses:

  • If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Exception Caught: SQLSTATE[42000]: Syntax error or access violation: 1305 FUNCTION usr_p533910_1.1AND does not exist:

Status Resolved
Add-on / Version Publisher 3.0.0
Severity
EE Version 5.3.0

Matthias Ballmann

Nov 01, 2019

hi brian,

I installed the 3.0.0 of publisher, downloaded today from your site and it works well on the greater part of the website. but on some pages I get these errors as seen in the screenshots attached.

this is the complete text error:

SQLSTATE[42000]: Syntax error or access violation: 1305 FUNCTION usr_p533910_1.1AND does not exist:
SELECT `ct`.*, `t`.*, `channel_title`, `c`.`channel_name`, `c`.`channel_url`, `c`.`comment_url`, `c`.`comment_moderate`, `c`.`channel_html_formatting`, `c`.`channel_allow_img_urls`, `c`.`channel_auto_link_urls`, `c`.`comment_system_enabled`, `username`, `m`.`email`, `m`.`screen_name`, `m`.`signature`, `m`.`sig_img_filename`, `m`.`sig_img_width`, `m`.`sig_img_height`, `m`.`avatar_filename`, `m`.`avatar_width`, `m`.`avatar_height`, `m`.`photo_filename`, `m`.`photo_width`, `m`.`photo_height`, `m`.`group_id`, `m`.`member_id`, `ct`.`url_title` AS default_url_title, `ct`.`status` AS status, `t`.`title` AS title, `t`.`site_id` AS entry_site_id, `exp_publisher_data_field_1`.`field_id_1` AS field_id_1, `exp_publisher_data_field_2`.`field_id_2` AS field_id_2, `exp_publisher_data_field_3`.`field_id_3` AS field_id_3, `exp_publisher_data_field_4`.`field_id_4` AS field_id_4, `exp_publisher_data_field_5`.`field_id_5` AS field_id_5, `exp_publisher_data_field_10`.`field_id_10` AS field_id_10, `exp_publisher_data_field_11`.`field_id_11` AS field_id_11, `exp_publisher_data_field_12`.`field_id_12` AS field_id_12, `exp_publisher_data_field_15`.`field_id_15` AS field_id_15, `exp_publisher_data_field_16`.`field_id_16` AS field_id_16, `exp_publisher_data_field_17`.`field_id_17` AS field_id_17, `exp_publisher_data_field_18`.`field_id_18` AS field_id_18, `exp_publisher_data_field_19`.`field_id_19` AS field_id_19, `exp_publisher_data_field_20`.`field_id_20` AS field_id_20, `exp_publisher_data_field_21`.`field_id_21` AS field_id_21, `exp_publisher_data_field_22`.`field_id_22` AS field_id_22, `exp_publisher_data_field_23`.`field_id_23` AS field_id_23, `exp_publisher_data_field_25`.`field_id_25` AS field_id_25, `exp_publisher_data_field_26`.`field_id_26` AS field_id_26, `exp_publisher_data_field_27`.`field_id_27` AS field_id_27, `exp_publisher_data_field_6`.`field_id_6` AS field_id_6, `exp_publisher_data_field_7`.`field_id_7` AS field_id_7, `exp_publisher_data_field_8`.`field_id_8` AS field_id_8, `exp_publisher_data_field_9`.`field_id_9` AS field_id_9, `exp_publisher_data_field_13`.`field_id_13` AS field_id_13, `exp_publisher_data_field_14`.`field_id_14` AS field_id_14 FROM (`exp_publisher_titles` AS t) JOIN `exp_channel_titles` AS ct ON `ct`.`entry_id` = `t`.`entry_id` JOIN `exp_channels` AS c ON `c`.`channel_id` = `t`.`channel_id` LEFT JOIN `exp_publisher_data_field_1` ON `t`.`entry_id` = `exp_publisher_data_field_1`.`entry_id` AND t.lang_id = exp_publisher_data_field_1.lang_id AND t.status = exp_publisher_data_field_1.status AND exp_publisher_data_field_1.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_2` ON `t`.`entry_id` = `exp_publisher_data_field_2`.`entry_id` AND t.lang_id = exp_publisher_data_field_2.lang_id AND t.status = exp_publisher_data_field_2.status AND exp_publisher_data_field_2.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_3` ON `t`.`entry_id` = `exp_publisher_data_field_3`.`entry_id` AND t.lang_id = exp_publisher_data_field_3.lang_id AND t.status = exp_publisher_data_field_3.status AND exp_publisher_data_field_3.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_4` ON `t`.`entry_id` = `exp_publisher_data_field_4`.`entry_id` AND t.lang_id = exp_publisher_data_field_4.lang_id AND t.status = exp_publisher_data_field_4.status AND exp_publisher_data_field_4.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_5` ON `t`.`entry_id` = `exp_publisher_data_field_5`.`entry_id` AND t.lang_id = exp_publisher_data_field_5.lang_id AND t.status = exp_publisher_data_field_5.status AND exp_publisher_data_field_5.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_10` ON `t`.`entry_id` = `exp_publisher_data_field_10`.`entry_id` AND t.lang_id = exp_publisher_data_field_10.lang_id AND t.status = exp_publisher_data_field_10.status AND exp_publisher_data_field_10.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_11` ON `t`.`entry_id` = `exp_publisher_data_field_11`.`entry_id` AND t.lang_id = exp_publisher_data_field_11.lang_id AND t.status = exp_publisher_data_field_11.status AND exp_publisher_data_field_11.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_12` ON `t`.`entry_id` = `exp_publisher_data_field_12`.`entry_id` AND t.lang_id = exp_publisher_data_field_12.lang_id AND t.status = exp_publisher_data_field_12.status AND exp_publisher_data_field_12.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_15` ON `t`.`entry_id` = `exp_publisher_data_field_15`.`entry_id` AND t.lang_id = exp_publisher_data_field_15.lang_id AND t.status = exp_publisher_data_field_15.status AND exp_publisher_data_field_15.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_16` ON `t`.`entry_id` = `exp_publisher_data_field_16`.`entry_id` AND t.lang_id = exp_publisher_data_field_16.lang_id AND t.status = exp_publisher_data_field_16.status AND exp_publisher_data_field_16.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_17` ON `t`.`entry_id` = `exp_publisher_data_field_17`.`entry_id` AND t.lang_id = exp_publisher_data_field_17.lang_id AND t.status = exp_publisher_data_field_17.status AND exp_publisher_data_field_17.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_18` ON `t`.`entry_id` = `exp_publisher_data_field_18`.`entry_id` AND t.lang_id = exp_publisher_data_field_18.lang_id AND t.status = exp_publisher_data_field_18.status AND exp_publisher_data_field_18.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_19` ON `t`.`entry_id` = `exp_publisher_data_field_19`.`entry_id` AND t.lang_id = exp_publisher_data_field_19.lang_id AND t.status = exp_publisher_data_field_19.status AND exp_publisher_data_field_19.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_20` ON `t`.`entry_id` = `exp_publisher_data_field_20`.`entry_id` AND t.lang_id = exp_publisher_data_field_20.lang_id AND t.status = exp_publisher_data_field_20.status AND exp_publisher_data_field_20.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_21` ON `t`.`entry_id` = `exp_publisher_data_field_21`.`entry_id` AND t.lang_id = exp_publisher_data_field_21.lang_id AND t.status = exp_publisher_data_field_21.status AND exp_publisher_data_field_21.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_22` ON `t`.`entry_id` = `exp_publisher_data_field_22`.`entry_id` AND t.lang_id = exp_publisher_data_field_22.lang_id AND t.status = exp_publisher_data_field_22.status AND exp_publisher_data_field_22.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_23` ON `t`.`entry_id` = `exp_publisher_data_field_23`.`entry_id` AND t.lang_id = exp_publisher_data_field_23.lang_id AND t.status = exp_publisher_data_field_23.status AND exp_publisher_data_field_23.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_25` ON `t`.`entry_id` = `exp_publisher_data_field_25`.`entry_id` AND t.lang_id = exp_publisher_data_field_25.lang_id AND t.status = exp_publisher_data_field_25.status AND exp_publisher_data_field_25.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_26` ON `t`.`entry_id` = `exp_publisher_data_field_26`.`entry_id` AND t.lang_id = exp_publisher_data_field_26.lang_id AND t.status = exp_publisher_data_field_26.status AND exp_publisher_data_field_26.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_27` ON `t`.`entry_id` = `exp_publisher_data_field_27`.`entry_id` AND t.lang_id = exp_publisher_data_field_27.lang_id AND t.status = exp_publisher_data_field_27.status AND exp_publisher_data_field_27.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_6` ON `t`.`entry_id` = `exp_publisher_data_field_6`.`entry_id` AND t.lang_id = exp_publisher_data_field_6.lang_id AND t.status = exp_publisher_data_field_6.status AND exp_publisher_data_field_6.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_7` ON `t`.`entry_id` = `exp_publisher_data_field_7`.`entry_id` AND t.lang_id = exp_publisher_data_field_7.lang_id AND t.status = exp_publisher_data_field_7.status AND exp_publisher_data_field_7.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_8` ON `t`.`entry_id` = `exp_publisher_data_field_8`.`entry_id` AND t.lang_id = exp_publisher_data_field_8.lang_id AND t.status = exp_publisher_data_field_8.status AND exp_publisher_data_field_8.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_9` ON `t`.`entry_id` = `exp_publisher_data_field_9`.`entry_id` AND t.lang_id = exp_publisher_data_field_9.lang_id AND t.status = exp_publisher_data_field_9.status AND exp_publisher_data_field_9.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_13` ON `t`.`entry_id` = `exp_publisher_data_field_13`.`entry_id` AND t.lang_id = exp_publisher_data_field_13.lang_id AND t.status = exp_publisher_data_field_13.status AND exp_publisher_data_field_13.is_fluid = 0 LEFT JOIN `exp_publisher_data_field_14` ON `t`.`entry_id` = `exp_publisher_data_field_14`.`entry_id` AND t.lang_id = exp_publisher_data_field_14.lang_id AND t.status = exp_publisher_data_field_14.status AND exp_publisher_data_field_14.is_fluid = 0 JOIN `exp_members` AS m ON `m`.`member_id` = `t`.`author_id` WHERE `t`.`entry_id` IN (73, 14, 6, 2, 11) AND `t`.`status` = ‘open’ AND `t`.`lang_id` = 1AND ( (d.site_id=1 AND exp_channel_data_field_9.field_id_9!=”” AND d.site_id=1 AND exp_channel_data_field_9.field_id_9 IS NOT NULL) )

ee/legacy/database/drivers/mysqli/mysqli_connection.php:117

Stack Trace: Please include when reporting this error

#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query(‘SELECT `ct`.*, ...’)
#1 ee/legacy/database/DB_driver.php(270): CI_DB_mysqli_driver->_execute(‘SELECT `ct`.*, ...’)
#2 ee/legacy/database/DB_driver.php(180): CI_DB_driver->simple_query(‘SELECT `ct`.*, ...’)
#3 user/addons/publisher/Service/Entry/EntryQuery.php(209): CI_DB_driver->query(‘SELECT `ct`.*, ...’)
#4 user/addons/publisher/Service/Entry/EntryResult.php(501): BoldMinded\Publisher\Service\Entry\EntryQuery->getResultArray()
#5 user/addons/publisher/Service/Entry/EntryResult.php(219): BoldMinded\Publisher\Service\Entry\EntryResult->getAllQuery(Array, Array)
#6 user/addons/publisher/ext.publisher.php(885): BoldMinded\Publisher\Service\Entry\EntryResult->getAll(Array, Array)
#7 ee/legacy/libraries/Extensions.php(222): Publisher_ext->channel_entries_query_result(Object(Channel), Array)
#8 ee/legacy/libraries/Extensions.php(117): EE_Extensions->call_class(‘Publisher_ext’, ‘channel_entries…’, Array, Array)
#9 ee/EllisLab/Addons/channel/mod.channel.php(2779): EE_Extensions->call(‘channel_entries…’, Object(Channel), Array)
#10 ee/EllisLab/Addons/channel/mod.channel.php(281): Channel->parse_channel_entries()
#11 ee/legacy/libraries/Template.php(1847): Channel->entries()
#12 ee/legacy/libraries/Template.php(1482): EE_Template->process_tags()
#13 ee/legacy/libraries/Template.php(578): EE_Template->tags()
#14 ee/legacy/libraries/Template.php(234): EE_Template->parse(’{!—ra:0000000…’, false, 1, false)
#15 ee/legacy/libraries/Template.php(165): EE_Template->fetch_and_parse(’‘, Array, false)
#16 ee/legacy/libraries/Core.php(661): EE_Template->run_template_engine(’‘, ‘’)
#17 ee/legacy/controllers/ee.php(63): EE_Core->generate_page()
#18 [internal function]: EE->index()
#19 ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array)
#20 ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#21 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#22 files/index.php(191): require_once(’...’)
#22 files/index.php(191): require_once(’...’)

 

#1

BoldMinded (Brian)

Nov 01, 2019

Comment has been marked private.

#2

Matthias Ballmann

Nov 01, 2019

yes it is.

#3

BoldMinded (Brian)

Nov 01, 2019

What version of MySQL and PHP?

#4

Matthias Ballmann

Nov 01, 2019

mysql 5.7.18 and php 7.3

#5

BoldMinded (Brian)

Nov 01, 2019

What exactly is this page doing? Just a normal entries tag? If so can you post the opening tag so I can see the parameters you used?

#6

Matthias Ballmann

Nov 01, 2019

this is the code.
it just displays text and a list on the bottom of the page which lists names of people featured on the site:

{!-- Mastertemplate --}
{layout="index/master"}

{!-- Seitentitel --}
{layout:set name="title" value="{phrase:impressum}"}

{!-- Seiteninhalte --}
<a class="legal">
 {exp:channel:entries channel="profil" disable="categories|category_fields|member_data|pagination|relationships"}
  <h1>{phrase:impressum}</h1>
  {impressum}
 {/exp:channel:entries}
 {exp:channel:entries channel="projekte" search:bildnachweise="not IS_EMPTY" orderby="bildnachweise" sort="asc" disable="categories|category_fields|member_data|pagination|relationships"}
  {if count == 1}
    
   
   <strong>{phrase:bildnachweise}</strong>
   
   
  {/if}
  {bildnachweise}{if absolute_results >= 2 AND count != absolute_results}, {/if}
  {if count == absolute_results}
   
  {/if}
 {/exp:channel:entries}
</article>
#7

BoldMinded (Brian)

Nov 01, 2019

I know what the fix is but I’m just not exactly sure where it is. I should have a new build for you by the end of the weekend.

#8

BoldMinded (Brian)

Nov 02, 2019

Comment has been marked private.

#9

Matthias Ballmann

Nov 03, 2019

Comment has been marked private.

#10

Matthias Ballmann

Nov 03, 2019

Comment has been marked private.

#11

Matthias Ballmann

Nov 03, 2019

Comment has been marked private.

#12

BoldMinded (Brian)

Nov 03, 2019

I wasn’t able to replicate the second query error, but I was able to replicate the first one you reported, which is how I fixed it.

Are you sure the exp_publisher_data_field_9 table exists and the field_id_9 column is in it? What is field #9? Is it the bildnachweise field?

#13

Matthias Ballmann

Nov 04, 2019

I just looked in the db and…

exp_publisher_data_field_9 exists with 10 entries.
and yes: one of the columns is named field_id_9.

#14

BoldMinded (Brian)

Nov 04, 2019

Can you edit the ticket and add ftp and cp access so I can take a look? Make sure the Publisher directory is writable too, and put the problem entries tag into a new template with no additional HTML or css, just enough of the entries tag to reproduce the error.

#15

Matthias Ballmann

Nov 04, 2019

Comment has been marked private.

#16

BoldMinded (Brian)

Nov 04, 2019

Thanks for the info. It may take a day or two to figure this one out. It appears to only be an issue when 2 entries tags are on the page at the same time. I have a good idea of where the issue is happening, just need to determine why it is happening.

#17

BoldMinded (Brian)

Nov 04, 2019

Comment has been marked private.

#18

Matthias Ballmann

Nov 04, 2019

Comment has been marked private.

#19

BoldMinded (Brian)

Nov 04, 2019

Awesome! You can use it on another site, I’ll release a 3.0.1 update in the next day or so with this fix.

#20

Matthias Ballmann

Nov 12, 2019

Comment has been marked private.

#21

BoldMinded (Brian)

Nov 12, 2019

Comment has been marked private.

#22

BoldMinded (Brian)

Nov 14, 2019

Matthias, can you confirm if the build I sent fixed the issue?

#23

Matthias Ballmann

Nov 15, 2019

hi brain,
It looks as if the error of the emptied fields has been corrected. However, it now seems as if there is an switching of the language versions in the mass edit mode, because after I inserted all English versions of the texts yesterday (via mass edit), now all German texts are English… and the English versions are still empty or missing.

But if you edit an entry individually, everything seems to be correct.

#24

BoldMinded (Brian)

Nov 15, 2019

When you do the mass edit, do you have the CP set to your default language or non-default language?

#25

BoldMinded (Brian)

Nov 27, 2019

Matthias, just to make sure I’m replicating this, you checked multiple entries and then selected Edit, not Bulk Edit, correct? screenshot: https://d.pr/i/gdB6sv

And then when you were editing, did you see your default language or non-default language in the upper right corner? screenshot: https://d.pr/i/N3Izel

#26

BoldMinded (Brian)

Nov 27, 2019

Comment has been marked private.

#27

Matthias Ballmann

Dec 02, 2019

sorry brian, we have a lot to do so shortly before christmas. so i didn’t get to see the new build yet.

#28

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#29

BoldMinded (Brian)

Dec 03, 2019

What are you doing to get that error? What does your entries tag look like? I need to be able to replicate it.

#30

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#31

BoldMinded (Brian)

Dec 03, 2019

That conditional isn’t executing any queries, what is the entries tag that is around it?

#32

Matthias Ballmann

Dec 03, 2019

it’s this:

{exp:channel:entries channel="shop" search:art_des_shopartikels="Bücher und Kataloge" status="not vergriffen" orderby="random" dynamic="no" limit="10" disable="categories|category_fields|member_data"}
#33

BoldMinded (Brian)

Dec 03, 2019

That is what I needed, thanks. I’ll test it locally and see what happens. Could be a day or two before I get a new build to you.

#34

BoldMinded (Brian)

Dec 03, 2019

What is “not vergriffen” in English?

#35

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#36

BoldMinded (Brian)

Dec 03, 2019

I just tried a similar tag locally, and it worked fine in default and non-default languages.

{exp:channel:entries channel="pages" search:heading="one" status="not closed" orderby="random" dynamic="no" limit="10" disable="categories|category_fields|member_data"}
 {title}
{/exp:channel:entries}
#37

BoldMinded (Brian)

Dec 03, 2019

Are you positive the field “art_des_shopartikels” exists on your site? Have you tried searching a different field for perhaps different text? Have you tried removing 1 of those parameters at a time in the entries tag until it works to hopefully identify which parameter is causing a problem?

#38

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#39

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#40

Matthias Ballmann

Dec 03, 2019

all the other tags doesn’t seem to influence the error.
only removing the search-tag solves the error.

#41

BoldMinded (Brian)

Dec 03, 2019

How many custom fields are assigned to the shop channel?

#42

BoldMinded (Brian)

Dec 03, 2019

In the EntryQuery.php file, line 116 you should see this:

$this->customFields = $this->fieldSchema->getCustomFieldTables();

Add after that line:

var_dump($this->customFields);

And paste the output here.

#43

Matthias Ballmann

Dec 03, 2019

there are 11 custom fields.

#44

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#45

BoldMinded (Brian)

Dec 03, 2019

Are you able to edit the ticket and provide CP login and FTP access so I can debug on your site? If so double check that the publisher folder and files are writable. (I’ve had people send ftp access without write access, just want to avoid additional back and forth)

#46

Matthias Ballmann

Dec 03, 2019

Comment has been marked private.

#47

BoldMinded (Brian)

Dec 03, 2019

Comment has been marked private.

#48

BoldMinded (Brian)

Dec 04, 2019

Are you positive the FTP credentials you provided work? I can’t seem to login. Using TLS/SSL mode.

#49

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#50

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#51

BoldMinded (Brian)

Dec 04, 2019

Comment has been marked private.

#52

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#53

BoldMinded (Brian)

Dec 04, 2019

Comment has been marked private.

#54

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#55

BoldMinded (Brian)

Dec 04, 2019

Ok, so test _just_ the structure:nav tag in a template.

{exp:structure:nav_advanced}{root:children}{if child:active}{child:title} – {/if}{/root:children}{if root:active}{root:title}{/if}{/exp:structure:nav_advanced}

If there are multiple tags running on the page it makes it more difficult to debug. We need to narrow it down to a single tag that is causing the error, then I can look into it.

#56

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#57

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#58

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#59

BoldMinded (Brian)

Dec 04, 2019

I’m not logged in and won’t be able to agin until tonight or tomorrow.

What do you mean by rollback? Will rolling back stop the error from occurring and remove those test templates? If so they’ll need to be added back so I can debug.

#60

Matthias Ballmann

Dec 04, 2019

Comment has been marked private.

#61

BoldMinded (Brian)

Dec 09, 2019

Matthias, just checking in on the status of this. Did the rollback fix it? If not were you able to re-create the test/debug template I made?

Login to reply

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.