Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Fatal Error after updating to Publisher 3.0.0

Status Resolved
Add-on / Version Publisher 3.0.0
Severity
EE Version 5.3.0

Matthias Ballmann

Oct 23, 2019

hi brian,

I tried to install the new 3.0.0 of publisher on our testserver and ran into this error immediately after replacing the current dirs:

Fatal error: Uncaught Error: Class ‘Basee\Ping’ not found in /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/user/addons/publisher/ext.publisher.php:2071 Stack trace: #0 /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/user/addons/publisher/ext.publisher.php(324): Publisher_ext->validateLicense() #1 /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/ee/legacy/libraries/Extensions.php(222): Publisher_ext->core_boot() #2 /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/ee/legacy/libraries/Extensions.php(117): EE_Extensions->call_class(‘Publisher_ext’, ‘core_boot’, Array, Array) #3 /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/ee/legacy/core/Controller.php(85): EE_Extensions->call(‘core_boot’) #4 /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/ee/legacy/core/Controller.php(99): EE_Controller->__construct() #5 /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system in /var/www/vhosts/lvps92-51-135-39.dedicated.hosteurope.de/httpdocs/system/user/addons/publisher/ext.publisher.php on line 2071


kind regards
matthias

#1

BoldMinded (Brian)

Oct 23, 2019

If you’re using other add-ons of mine, such as Bloqs, make sure you upgrade those too.

#2

BoldMinded (Brian)

Oct 23, 2019

Actually sorry, looks like I forgot to do something. I’ll send a new build shortly.

#3

BoldMinded (Brian)

Oct 23, 2019

Comment has been marked private.

#4

Matthias Ballmann

Nov 01, 2019

the build you’ve provided seems to work.

did you already modify the official build? because my colleague updated another website with that one and it worked without problems.

#5

BoldMinded (Brian)

Nov 01, 2019

Yes, the build I sent is the official release.

#6

Matthias Ballmann

Nov 01, 2019

The original error no longer exists, but there is now another one. I just uploaded three screenshots attached to this ticket.

#7

BoldMinded (Brian)

Nov 01, 2019

I don’t see the screenshot. If it’s a new error, can you create a new ticket?

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.