Be sure to checkout our newest add-on, Speedy — Advanced Caching for ExpressionEngine.

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: The url title in the URL is not translated.

Status Resolved
Add-on / Version Publisher 2.11.2
Severity
EE Version 5.3.0

pixi

Oct 02, 2019

Hi, me again, sorry :-s .

I Don’t know if the trouble was already there before installing add-ons so this time I have uninstalled every add-on to see if this was a conflict but uninstall doesn’t fix it.
I also deleted my htaccess file to see if it doesn’t cause the issue, it doesn’t.

When I am on an entry (in French) and switch to the Deutch version, the entry is correctly translated, the template group and template are correctly translated in the URL but not the entry title. When I output {entry title} into the template, it is correctly translated. It doesn’t only in the URL.

I tested this : I’m on the entry in french where the url title is “a-propos”, URL is correct in french. I switch in deutch—> it has the issue. Then I manually wrote the correct url title “over-ons” into the URL—> the entry is still well translated. Then I switched back to FR—> the url title in the URL is the deutch url title “over-ons”...

I hope it is enough detailed to let you see what goes wrong.

Enable URL translations is set to ON.
I emptied my caches (both EE and browsers)

 

#1

BoldMinded (Brian)

Oct 02, 2019

Can you take a video capture displaying the issue? Including the entry in the control panel so I can see the whole process that you’re seeing?

#2

pixi

Oct 02, 2019

Comment has been marked private.

#3

BoldMinded (Brian)

Oct 05, 2019

Do you have any categories, templates, or other entries that also have the title “a-propos” or “over-bvvm”?

#4

pixi

Oct 05, 2019

I have no categories. no templates named like that and no other entries names like that.

#5

BoldMinded (Brian)

Oct 05, 2019

Can you edit the ticket and provide a CP login to a development environment so I can take a look?

Also please share the entry_id you’re referring to, and the template file that was used in the video to display the issue.

#6

pixi

Oct 05, 2019

Ok, I just edit the ticket.

entry_id : 1

<!--main content:start-->
        <main id="content">
            {exp:channel:entries channel="qui_sommes_nous" limit="1" disable="categories|category_fields|member_data|pagination" sort="asc"}
            {exp:publisher:languages entry_id="{entry_id}" show_current="no"}
            <div class="langue{if is_active} active{/if}">
                {if is_active}{if:else}<a href="http://{switch_language_url}" title="{long_name}">{/if}{short_name}{if is_active}{if:else}</a>{/if}
            </div>
            {/exp:publisher:languages}
            <h1>{title}</h1>
            URL title : {url_title}
            <div id="corps_de_page">{corps_de_page}</div>
            {/exp:channel:entries}
        </main>
        <!--main content:stop-->
#7

BoldMinded (Brian)

Oct 05, 2019

Comment has been marked private.

#8

pixi

Oct 06, 2019

just installed it but it doesn’t change anything.

But it seems like on Add-On Manager > Publisher > General Settings it is still 2.11.2 build cbd0133b (even if cache have been cleared).

#9

BoldMinded (Brian)

Oct 07, 2019

If your build shows “cbd0133b” then it definitely does not have the correct files installed. It should be “376923c6”.

#10

pixi

Oct 08, 2019

Ok I downloaded your build again and re-installed it and now the version is correct. The issue is still there whith the last build.

#11

BoldMinded (Brian)

Oct 08, 2019

Have you tried replicating this in a clean environment?

#12

pixi

Oct 09, 2019

Hi Brian,

I just did on a brand new environment and the issue is there too. I set the add-ons with the same settings and I tested with the same bare test template.

If it can help you with your investigations, here is what I noticed too on my dev website and on the new environment :

If I start to visit the website in french (which is the default language), I go to my template where the content is in french. I switch and it shows me the content in dutch but as you know it doesn’t show the translated url title in the browser’s URL. If I switch back to default language I see the content in french again.

BUT If I start to visit the website in dutch, I go to my template where the content is in dutch, then I change manually the url_title in the browser’s URL with the dutch version of the entry’s url_title. Then I switch and it doesn’t show the french translated entry title in the URL AND it doesn’t show me the content in french because ir relies on require_entry=“yes” and as he can’t find the entry because the url_title is still in dutch…

I hope you’ll find a solution. Thanks in advance.

#13

BoldMinded (Brian)

Oct 09, 2019

Comment has been marked private.

#14

pixi

Oct 09, 2019

I just did on my new clean installation but it doesn’t change anything…

#15

BoldMinded (Brian)

Oct 09, 2019

Comment has been marked private.

#16

pixi

Oct 09, 2019

It seems to fix the issue on my clean installation but let me check this out on the real dev website at my office tomorrow before closing the ticket please. Already a big thank you.

I just noticed this that maybe is nothing : as I checked this build by switching between languages several times in a row, sometimes randomly I end up having this error message (maybe it’s just if I switch too fast) :

Error

The page you requested was not found.

#17

pixi

Oct 10, 2019

It’s a confirmation, this build fixed the issue. Phew!

Thank you very much!

#18

BoldMinded (Brian)

Oct 10, 2019

Excellent! Sorry it took so long to get there 😊

#19

pixi

Oct 16, 2019

Hi Brian, sorry I’m back…

It seems that the issue persists in some cases I didn’t noticed before. How can I show you, can you connect you on the staging website or?

I’m on french version of event’s index (let’s say url/fr/intranet/evenements), I switch on ducth version and the URL translate like this url/nl/intranet/events but when I switch back to french the url is url/fr/intranet/events.
Same here : I’m on french version of an event (url/fr/intranet/evenement/evenement-numero-1),  I switch on ducth version and the URL translate like this url/nl/intranet/event/event-numer-1 but when I switch back to french the url is url/fr/intranet/event/evenement-numero-1.
For the record: it is normal that the word intranet is not translated cause it is the same in french and in dutch.

Don’t know why it occurs only in some cases, I couln’t find a specific path.

I could reproduce it on my clean installation.

Thanks in advance for your support.

#20

pixi

Oct 16, 2019

it is nit the url_title anymore but it is still comething in the url

#21

BoldMinded (Brian)

Oct 16, 2019

Please edit the ticket and re-add the CP and FTP login info. Also make sure that the templates in question are stripped down to only the EE code necessary to reproduce the issue.

#22

pixi

Oct 16, 2019

Comment has been marked private.

#23

BoldMinded (Brian)

Oct 16, 2019

Can you add FTP info too? So I can debug the code to see what is happening.

#24

pixi

Oct 16, 2019

Sure, I just edited the ticket 😉

#25

BoldMinded (Brian)

Oct 16, 2019

Have you tried using {translated_url} instead of {switch_language_url}? If you’re just wanting to switch languages it’ll basically do the same thing.

#26

pixi

Oct 17, 2019

Never tried before. It seems to do the trick for the URL… :D What’s the difference? Thanks.
I can’t hope this to be done because now I have to go back to Super Restricted Entries ad-on developper because when I apply

{exp:channel:entries channel="pages_intranet" dynamic="no" disable="categories|category_fields|member_data|pagination" orderby="title" sort="asc" apply_super_restricted_entries="yes"}
                        <li><a href="http://{url_title_path=intranet/page}">{title}</a></li>
                        {/exp:channel:entries}

it output me the entrie’s title in french even when I am on dutch version of the website. Maybe it is a parsing order thing? Publisher occurs before Super Restricted Entries maybe.

Soon I will not have any hair to tear off.

#27

BoldMinded (Brian)

Oct 17, 2019

switch_language_url was the original way to do the language switcher, but over time translated_url was improved and basically does the same thing. I’m thinking of marking switch_language_url as deprecated b/c it’s actually more complex than it needs to be.

Check out comment #5, it should fix Super Restricted Entries https://boldminded.com/support/ticket/2014#comment5

#28

BoldMinded (Brian)

Oct 18, 2019

Going to close this out. I think I fixed the switch_language_url variable, but I’m going to include that in the Publisher 3.0 release. I’m trying to stop work on the 2.x branch and deprecate it. 3.0 should be released next week.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.