All add-ons currently require PHP 7.4 or greater.

On July 4th 2024 PHP 8.2 will be the new minimum requirement for all add-ons. Expect any add-on released after that date to require 8.2 or greater. Some releases may not immediately take advantage of 8.x specific features in PHP, which means you might, be able to continue using new releases in PHP 7.4, however, if you experience an error the first thing you should do is update to PHP 8.2 then create a support ticket if the error persists.

Publisher does not support the Fluid field type. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Unable to save loaded revision data that includes fields that have been deleted

Status Resolved
Add-on / Version Publisher Lite 2.11.2
Severity
EE Version 5.1.1

Mighty Citizen

Sep 19, 2019

Steps to reproduce:
- Delete field from channel
- Load old revision where entry had data in that deleted field
- Try to save

#1

BoldMinded (Brian)

Thanks for reporting this, but its been a crazy few weeks, and I won’t have time to look into this until after the conference, which is the week of the 7th.

#2

Mighty Citizen

Thanks for the update, Brian

#3

BoldMinded (Brian)

I just got around to trying to replicate this and can’t. Can you share a video of the sequence to replicate and the error message you’re getting?

#4

Mighty Citizen

Here you go: https://drive.google.com/file/d/1_bTlZLYXhSr3S-Zp9OU_pBL7IVbzSFy2/view

#5

BoldMinded (Brian)

Thanks for the video and pointing out the issue. This seems like a pretty edge case issue, so I put the fix into the Publisher 3 branch, and it’ll be included in the 3.0 beta release soon.

#6

Mighty Citizen

Sounds good - I’ll give that a shot. Thanks!

Login to reply