Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Simple Grid data disappears during validation

Status Resolved
Add-on / Version Simple Grids & Tables 1.1.1
Severity
EE Version 5.2.6

Jennifer Martin

Aug 08, 2019

Hi Brian,
I’m getting a pretty major issue in that my Simple Grid data disappears from Fluid Field in the Publish screen upon attempting to save where a different element in the Fluid Field has an error.  In my specific case, my Simple Grid is also inside a normal Grid which is available to the Fluid Field.

This is a big issue - with large pages, the missing data isn’t easily noticeable and as soon as the user fixes the error in the other field and saves their change, it removes the data from the Simple Grid permanently.

Are you able to replicate this?  Feel free to hit me up on slack if you need more info @pyrobob83 and I can give FTP access if needed.

Thanks,
Justin

#1

BoldMinded (Brian)

Aug 08, 2019

Comment has been marked private.

#2

Jennifer Martin

Aug 09, 2019

Hi Brian,
No, sorry - I still get the same thing.  I actually first noticed this in the pre-release build you sent me in response to the request to add a URL field type, then tried rolling back to 1.1.1 and it happens in all of those builds, including this latest one you sent me.

Thanks,
Justin

#3

BoldMinded (Brian)

Aug 09, 2019

Are you sure? I tested this quite a bit last night and the grid and table fields definitely displayed the correct values when the page was submitted with invalid data and reloaded. Before the changes I made last night I saw the table rows disappearing. Can you provide a video of what you’re encountering?

#4

Jennifer Martin

Aug 09, 2019

Yes - I’m using your latest pre-release build and made 100% sure nothing was caching by using an incognito/private browser window.  To add clarity, ‘block’ available to the Fluid Field that has required fields and is throwing the validation error is *not* the same as the block with the Simple Grid inside a Grid.  I couldn’t upload a video here, but will send via Slack

#5

BoldMinded (Brian)

Aug 09, 2019

Comment has been marked private.

#6

Jennifer Martin

Aug 09, 2019

Yes!  That’s fixed this - thanks Brian for the excellent support!

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.