Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: No Low Search results for page when using Bloqs, Publisher, and Publisher Low Search

Status Resolved
Add-on / Version Publisher Low Search 3.0.0
Severity
EE Version 5.2.2

Nick Johnson

May 06, 2019

Client site is using Bloqs 4.0.19, Publisher 2.10.8, and Publisher Low Search 3.0.0, but is returning 0 results for entries with the correct search term. All Bloqs atoms and the Bloqs field are set to searchable (before any content was added), entries have been re-saved multiple times, and the Low Search collection has been re-indexed multiple times but there are still no results.

I had originally opened a help topic with Low here before I remembered that Publisher was involved: https://getsatisfaction.com/low/topics/bloqs-fields-not-being-indexed-by-low-search.

#1

BoldMinded (Brian)

May 06, 2019

Does this happen in the default language or any language? Find the field of of your Bloqs field, then go to the exp_publisher_data table and find the field_id_x column for that id…. does it contain a concatenated string of all the text entered into the atoms of that Bloqs field? Did you check the Low Search tables directly to se of the data you expect to be searchable is present in the index?

#2

Nick Johnson

May 06, 2019

This is happening in the default language, as they currently don’t have any entries with additional languages added (it’s set up for them to add in the future as they’re ready to do so).

exp_publisher_data does not have any data whatsoever in the field_id_79 column (this is the only Bloqs field in our setup).

#3

BoldMinded (Brian)

May 06, 2019

What do the results say when you go to Publisher > Utilities > Diagnostics?

#4

Nick Johnson

May 06, 2019

“Good to go! It looks like all of Publisher’s hooks are installed and enabled.”

#5

BoldMinded (Brian)

May 06, 2019

It looks like this broke due to a change to fix a different issue. This may take a week or two to sort out (mostly b/c I’m about to go on a short vacation).

#6

BoldMinded (Brian)

May 07, 2019

Comment has been marked private.

#7

BoldMinded (Brian)

May 07, 2019

I just tested those builds again in a different environment and while I didn’t test it with Low Search specifically, I can confirm that Publisher and Bloqs are saving the data correctly now so it can be indexed.

#8

Nick Johnson

May 08, 2019

Thanks Brian!

It did require those entries to be re-saved, but it is properly indexing and returning those entries now. Thanks again!

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.