Be sure to checkout our newest add-on Reading Time Pro!

EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Preview function SQL error after plugin update

Status Resolved
Add-on / Version Publisher 2.10.8
Severity
EE Version 4.3.8

Martyn Tan

May 02, 2019

Hi Support,

Recently we updated EE, Bloqs and Publisher to the latest version and the preview module is having SQL issues. Attached is a screenshot of what is shown when we are trying to preview an entry.

#1

BoldMinded (Brian)

May 02, 2019

Martyn, can you paste the full error message into a comment instead of a screenshot?

#2

Martyn Tan

May 02, 2019

Hi Brian,

Here’s the error message. I’ve uploaded as a text file as there is a limit of characters for the comment box.
https://staging.capellahotels.com/temp/__sqlerror.txt

#3

BoldMinded (Brian)

May 02, 2019

Thanks for the error text. Can you be more descriptive in describing the issue? What exactly are you doing when this error occurs? Are you doing a Live Preview? Or does this happen on the front-end? A video of the issue happening would help so I can see exactly what is occurring.

#4

Martyn Tan

May 02, 2019

Yes the error occurs on certain pages when we use the preview button to see what is changed. The page over at the front end is alright without any issues. I’ve attached a link to the video showing what is happening. Some pages will get the error others don’t.

https://drive.google.com/file/d/1BBmeb_NHdHdj-Rhh4_xr2FTjI7_gfcFs/view

#5

BoldMinded (Brian)

May 02, 2019

I still need some more info which isn’t really revealed in the video. So what is unique about those pages that the error is occurring on? What are the custom fieldtypes? Does it have a Bloqs field on the page? If so what blocks are assigned to the page? Be as detailed as possible please.

Have you tried creating a new channel with only the custom fields necessary to replicate the issue?

#6

Martyn Tan

May 03, 2019

The pages all use the same template and are of the same channel. They all have bloq fields in the page. No custom fieldtypes except the ones the that come native with EE.

After some testing I think I’ve zoom down to the issue. It seems like if we insert a block containing a relationship field and populate it will generate the sql error in the preview screen if that related entry is complex (another entry with grid or bloq field). Here is a video of the error in action and the field that is causing the issue.

https://drive.google.com/file/d/1dFT0dHpD37xFGxmghOdtMTr3iDL_6cZg/view

#7

BoldMinded (Brian)

May 03, 2019

Martyn, I’m unable to replicate that locally, and due to what appears to be the pretty complex nature of your site you’ll need to replicate this in a brand new EE install with only Bloqs and Publisher installed before I can look into this. Replicating it in a simpler/cleaner environment will make it easier to debug, and may reveal what the issue is just by setting up the new environment. When you have this replicated in another environment you can edit this ticket to provide CP and FTP access and then I’ll take a look.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.