Be sure to checkout our newest add-on, Speedy — Advanced Caching for ExpressionEngine.

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Cannot delete all rows of a grid.

Status Resolved
Add-on / Version Publisher Lite 2.10.8 (06f710c2)
Severity
EE Version 5.2.1

Jim Stoll

Apr 23, 2019

This is related to #1949.

After creating and publishing an entry that contains a row in a grid field and then creating a draft of the same entry, the rows of the grid field cannot be removed from either a draft or a published version of the entry.

If you create an entry and only save as a draft. The grid field is updated correctly on subsequent edits. As long as the entry is never published.

Similarly,  if you create an entry and only save as published (never as a draft), then the grid field is updated correctly.

#1

BoldMinded (Brian)

Apr 24, 2019

Jim, what are your Persistence settings set to? Particularly Grid Persistence.

#2

BoldMinded (Brian)

Apr 24, 2019

Steps to replicate:

Create grid row save as draft
Delete grid row save as draft again, grid row will be empty
Add new grid row, save as published
Page reloads published version, delete grid row and save as draft
Page reloads showing published version, note grid row is still present
switch to view the draft, note grid rows are still present, but should not be.

#3

BoldMinded (Brian)

Apr 24, 2019
#4

Jonathan Dixon

Apr 24, 2019

Hi Brian,

I went through the entire settings menu for Publisher Lite multiple times and I cannot find any settings related to persistence. What am I missing?

#5

BoldMinded (Brian)

Apr 24, 2019

sorry, forgot you were using Lite. Persistence is a multi-lingual thing, so those settings are hidden from you.

#6

BoldMinded (Brian)

Apr 24, 2019

I think this is a bug with EE’s models. When deleting a Grid row it is not triggering the post_save hook, so Publisher isn’t able to do what it needs to do.

#7

Jonathan Dixon

Apr 24, 2019

Thanks Brian. I’ll look into that and gather what I need to file a bug report with EE.

#8

BoldMinded (Brian)

Apr 24, 2019

I created a ticket for EL to look into this. https://github.com/ExpressionEngine/ExpressionEngine/issues/193

#9

BoldMinded (Brian)

Apr 24, 2019

Don’t create a new ticket for them, use the one I created, it provides pretty specific info on where the issue is.

#10

BoldMinded (Brian)

May 08, 2019

Closing this b/c I can’t fix it.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.