Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Can’t switch and see translated version

Status Resolved
Add-on / Version Publisher 2.10.7
Severity
EE Version 5.1.3

Patterns.digital

Mar 14, 2019

Hi.
Url translation won’t work in my staging install.
If I follow a {title_permalink} it will preview as the right translation but then it will show the default language version in the address bar once the page is loaded.
If in this situation I hide the prefix I don’t even get the right translation, while if the prefixes are shown the correct version is presented but with the wrong url indication in the address bar. What is going on? Can you investigate?

#1

BoldMinded (Brian)

Mar 14, 2019

Can you please share the html code you used to render the link? Also a screenshot of your url translation settings?

#2

BoldMinded (Brian)

Mar 14, 2019

You also said “wrong url” - what is the correct url? I need a lot more information before I can look into this. Detailed steps to reproduce.

#3

BoldMinded (Brian)

Mar 14, 2019

The url you provided in the ticket does not work. If you’re providing an example of your error please make sure it is in a bare bones template with only the necessary code to reproduce the error. Also please point out which entry_ids are involved.

#4

Patterns.digital

Mar 18, 2019

Comment has been marked private.

#5

BoldMinded (Brian)

Mar 19, 2019

I haven’t had a chance to look into this yet. Have you tried {url_title_path=“template-group/template”}?

Also, please create a new test template with nothing else in it except for the absolute basic code to replicate this issue. You’ve linked to the home page of your site which doesn’t help me… I don’t know what link on the page is causing a problem. Please indicate which template file I need to look at, the URL I can see it at, and the entry_id you’re having trouble with. Thanks.

#6

BoldMinded (Brian)

Mar 26, 2019

Did you get a chance to create a test template that displays the issue for me? When I login to your test server I have no idea where to go or what to look at, which is why I need detailed steps to find and reproduce the issue. The simplified test template would be the easiest ways to do that. Did you try {url_title_path=“template-group/template”}?

#7

BoldMinded (Brian)

Apr 01, 2019

I’m closing this ticket b/c of no response in 2+ weeks.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.