EE4/5 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: ‘Safe Draft and Close’ works. ‘Save Draft And Preview’ *also* Publishes the entry

Status Resolved
Add-on / Version Publisher 2.10.7
Severity
EE Version 3.5.2

Paul Larson

Feb 11, 2019

Info to come (private)

#1

Paul Larson

Feb 11, 2019

Comment has been marked private.

#2

BoldMinded (Brian)

Feb 12, 2019

Paul, I hate doing this to you, but I stopped supporting add-ons in EE3 in December when it was retired. For this issue specifically, I know that the button names have changed in EE4/5, so the JS targeting those buttons may have different selectors that do not work in EE3 anymore. I’m happy to look into this once it’s upgraded to EE4 or or 5.

#3

Paul Larson

Feb 12, 2019

Comment has been marked private.

#4

Paul Larson

Feb 12, 2019

Comment has been marked private.

#5

BoldMinded (Brian)

Feb 13, 2019

Thanks for the video. I’m actually unable to replicate that. I did find a bug with the content diffs with Bloqs though… apparently that feature never worked with Bloqs :(

The only way I can mimic the behavior is if I explicitly put ?publisher_status=draft onto the URL on the front-end (and disable diffs), then it correctly shows the draft content on the front-end the same as it does in the CP preview modal.

What does your entries tag look like that it showing the bloqs content?

#6

Paul Larson

Feb 13, 2019

Comment has been marked private.

#7

Paul Larson

Feb 13, 2019

Comment has been marked private.

#8

BoldMinded (Brian)

Feb 13, 2019

Sorry, should have been more detailed. I used my local dev environment and was not able to replicate the issue. I saved an entry as draft, and the preview modal opened, showing the draft bloqs content. Then as you showed in your video I went to the front-end version of the entry and it showed the open/published version of the entry, not the newly saved draft content, which your video appeared to show. So the issue your video shows is that saving bloqs content as draft apparently saves it as open/published, not draft, as indicated by the result of viewing the entry on the front-end, _unless_ something else is at play on your site, which is why I asked for the template code.

#9

Paul Larson

Feb 13, 2019

Comment has been marked private.

#10

BoldMinded (Brian)

Feb 13, 2019

Nothing in your template code looks out of the ordinary. I also tested the behavior you showed in your video on jamf.com, which uses Publisher and Bloqs, and wasn’t able to replicate. Viewing the draft in the preview modal showed the correct content, and when I added ?publisher_status=draft to the front-end, it showed the correct draft content, but when I requested the open/published version of the same page (without ?publisher_status=draft) it showed the open/published content, not the newly saved draft content.

Usually at this point when I can’t replicate it I ask the customer to create a new EE install with only the add-ons involved in the issue, and just enough entries and template code to replicate the issue (usually 1 entry and 1 stripped down template file). Then from there if the new environment doesn’t show the same behavior, we can compare it to your non-working environment to figure out what the difference/cause of the issue is.

#11

BoldMinded (Brian)

Feb 13, 2019

(the CP login you provided doesn’t seem to let me in either)

#12

Paul Larson

Feb 13, 2019

Comment has been marked private.

#13

BoldMinded (Brian)

Feb 13, 2019

Have you tried replicating it in a clean/new environment?

#14

Paul Larson

Feb 14, 2019

Comment has been marked private.

#15

BoldMinded (Brian)

Feb 15, 2019

Paul, I saw your messages on Slack late yesterday, but I’m not sure of what the current status is. Did you end up narrowing it down or finding the possible issue?

#16

Paul Larson

Feb 15, 2019

Comment has been marked private.

#17

BoldMinded (Brian)

Feb 16, 2019

Were there some access permissions or something else assigned to the pages/.1col template that were not transferred to the new template? Publisher doesn’t really care what the template names are unless they have translated values for url translations.

#18

Paul Larson

Feb 20, 2019

Comment has been marked private.

#19

BoldMinded (Brian)

Feb 24, 2019

Just adding a note that I’ll look into this eventually, but from the sound of it, this could be a core EE issue b/c Publisher doesn’t really care about template caching, regardless of the scenario.

#20

Paul Larson

Feb 25, 2019

Mind testing it on one of your dev/production sites? That is, turn in template cache and attempt a draft preview?

#21

BoldMinded (Brian)

Apr 01, 2019

Closing b/c this is a template cache issue with the Live Preview feature, which I don’t think Publisher can do anything about.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.