Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Unable to translate categories

Status Resolved
Add-on / Version Publisher 2.9.0
Severity
EE Version 4.3.6

Aaron Jay

Feb 06, 2019

Hi, when I go into Add Ons > Publisher > Categories ,

I don’t get any option to translate the categories.  The list of categories on the site does not appear, I just get an empty section.  Do I have to enable this option anywhere?

#1

BoldMinded (Brian)

Feb 06, 2019

Looks like you are several versions behind. Try updating.

#2

Aaron Jay

Feb 06, 2019

Hi Brian,

Thanks for your help, I’ve set the site up locally and I’m trying to update to 2.10.7, but it’s not giving me the option to update, and seems to be trying to install a trial version?

Also, the categories seem to be working correctly locally, could it be a server environment issue?

#3

Aaron Jay

Feb 06, 2019

These are the messages I’m getting after I put the publisher 2.10.7 files into the admin and themes folders:

Notice
Use of undefined constant PUBLISHER_TRIAL - assumed ‘PUBLISHER_TRIAL’
user/addons/publisher/Service/Session.php, line 326

Severity: E_NOTICE
Warning
Cannot modify header information - headers already sent by (output started at ee/legacy/core/Exceptions.php:119)
ee/EllisLab/ExpressionEngine/Boot/boot.common.php, line 487

Severity: E_WARNING

#4

Aaron Jay

Feb 06, 2019

Never mind, the old folders we’re still in there, removing those looks to have allowed the update ok.  But is it possible that’s a server environment issue, could we fix this without having to update on the live site?

#5

BoldMinded (Brian)

Feb 06, 2019

But is it possible that’s a server environment issue, could we fix this without having to update on the live site?

Sorry, not sure exactly what you’re referring to here.

#6

Aaron Jay

Feb 06, 2019

Hi Brian,

No problem, the categories in Publisher 2.9 work ok on my locally version, but the exact same set up on the clients server, the categories don’t work.  I’m just wondering if there’s any server set up issue that might be causing it.  The PHP version or something like that. 

Locally, it’s on PHP 7.0.8, the clients server is PHP 7.1

#7

BoldMinded (Brian)

Feb 06, 2019

I don’t know of any sever specific issues that would cause this, but I do recall a similar bug report recently that was fixed, but apparently I didn’t note it in the change log. I think it had something to do with category groups and MSM sites. Is your site an MSM site?

#8

Aaron Jay

Feb 06, 2019

no it’s just a single site.  The database for both sites is the same so all category and member group permissions should be the same.

#9

Aaron Jay

Feb 06, 2019

Comment has been marked private.

#10

Aaron Jay

Feb 07, 2019

updating to 10.3.7 on the clients server has fixed this issue

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.