Be sure to checkout our newest add-on Reading Time Pro!

EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Adding a file to the file field in bloqs after clicking the trash bin doesnt work

Status Resolved
Add-on / Version Bloqs 4.0.18
Severity
EE Version EE 5.1.2

Kees Internetbureau

Jan 16, 2019

Hi Brian,

Ive made a video about the issue: https://we.tl/t-zG97TFOjEP
You can see that changing files from an entry edit does work, but its get broken when you delete the older image and try to add a new existing one.

#1

BoldMinded (Brian)

Jan 16, 2019

I actually was not able to replicate this. Have you tried to replicate in a new EE environment with only Bloqs installed? Do you see any errors in your JS console?

#2

Kees Internetbureau

Jan 17, 2019

It looks like this div get a class hidden when clicking the trash bin and the hidden class never gets removed after adding an image

<div class=“fields-upload-chosen”>

<div class=“fields-upload-chosen hidden”>

Ill try to make a fresh EE 5 install and test it and get back to you

#3

Kees Internetbureau

Jan 17, 2019

Comment has been marked private.

#4

BoldMinded (Brian)

Jan 17, 2019

Ok, maybe it has something to do with a new commit in EE that has not been rolled out into a release yet. Take a look at the stability branch in EE https://github.com/ExpressionEngine/ExpressionEngine/tree/stability and specifically this commit https://github.com/ExpressionEngine/ExpressionEngine/commit/8d4d946ed9061c336521a474d80993b10534f8a5

Either make those changes in the commit manually to your current EE codebase, or checkout the stability branch and see if the issue is resolved.

#5

Kees Internetbureau

Jan 17, 2019

Thanks ill try that.

BTW the “E-mail Address If you would like to subscribe to this ticket and recieve email notifications of follow-up responses enter your email address.” Doesnt work for me. i have to manually check the ticket.

#6

Kees Internetbureau

Jan 22, 2019

Hello,

I’ve found an issue with the new file field in EE 5.1.2 and bloqs 4.0.18. I’ve contacted Boldminded about this and he pointed us towards: https://github.com/ExpressionEngine/ExpressionEngine/commit/8d4d946ed9061c336521a474d80993b10534f8a5

I applied the fix and it seems to fix the editting images in bloqs, but it doesnt work when a bloqs block has multiple file fields. Changing one image will change them all. I assume the jquery is missing some sort of $(this) to only apply to the field you’re changing.

——————————

Hi Kees,

This looks like it may be a problem with bloqs. Brian from Boldminded is aware of it and has been working with Kevin from our team. He indicated that you should reach back out to him to resolve it.

Thanks Jordan Ellis (Ellislab)

#7

BoldMinded (Brian)

Jan 22, 2019

Comment has been marked private.

#8

Kees Internetbureau

Jan 23, 2019

Thanks! It seems to work now 😊 Can you release it into 4.0.19? Or do you have to wait till Ellislab launches their hotfix?

#9

BoldMinded (Brian)

Jan 23, 2019

Yeah, it’ll be in the 4.0.19 release. In the meantime I have to keep pointing people to that patch if they want it to work in 5.1.2.

#10

Kees Internetbureau

Jan 28, 2019

Hi There,

I just used this patch on a Multi-site website and it seems as though this doesn’t quite work yet.
The bloqs field is working fine on the first site(site_id 1) but doesn’t work at all on the second site(site_id 2).
I get the following Javascript error:
Uncaught TypeError: Cannot read property ‘label’ of undefined

on all pages with Bloqs. I hope you can help me out!

Kind regards,
Niels

#11

BoldMinded (Brian)

Jan 28, 2019

If you’re getting that error then it should say what line of code it is. I can help if you share the line of code that error is occurring on.

#12

Kees Internetbureau

Jan 29, 2019

Hi, it says the error is on line 171.

#13

BoldMinded (Brian)

Jan 29, 2019

And what file? None of the Bloqs JS files have anything relevant on line 171.

#14

Kees Internetbureau

Jan 30, 2019

Comment has been marked private.

#15

BoldMinded (Brian)

Jan 30, 2019

The only line of code in Bloqs’ JS files that contain “label” is a jQuery selector, which wouldn’t throw an undefined error. Also, that file you linked is EE’s compressed JS file, which none of Bloqs’ files are loaded in, so based on the error message and file you provided, this is not a Bloqs issue. Most likely something else is causing the error. If you can recreate the issue in a brand new install of EE with only Bloqs installed, then I’ll take a look at it, but right now I don’t have any reason to believe Bloqs is causing this error.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.