Be sure to checkout our newest add-on Reading Time Pro!

EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: All translations for entries got displayed

Status Resolved
Add-on / Version Publisher 2.10.5
Severity
EE Version 3.5.17

Hop Studios

Jan 02, 2019

Hello Brian,

We have a staging site that was just updated from EE2 (with publisher 1.7.5) to EE3. After upgrading Publisher to 2.10.5, all back end entries edit screens look correct.
However, in the front end, all translations seem to popup no matter what language we’re in (we have 8).
https://staging.lucistrust.org/nl/site/testing

GZip is turned off. Cache is disabled. I tried to follow all the tips that I’ve found from your documentations. Maybe it’s a setting that I missed? Were there any other additional steps that are required post EE2->3 upgrade?

* Also, {publisher:current_language_prefix} is empty.

 

#1

BoldMinded (Brian)

Jan 02, 2019

I feel like this has come up before. Have you searched the ticket history?

#2

BoldMinded (Brian)

Jan 02, 2019

Can you provide a couple of entry_ids that appear on the home page? I tried searching for “the group of world servers” and another string, but did not find the entries.

#3

BoldMinded (Brian)

Jan 02, 2019

Instead of me dealing with a full page template with a ton of queries and content I’m not familiar with, it would be easiest actually to create a test.group/index.html template with nothing in it but an entries tag with an entry_id=“ID” for one of the entries that appears to have duplicate results.

#4

BoldMinded (Brian)

Jan 02, 2019

Comment has been marked private.

#5

Hop Studios

Jan 02, 2019

Comment has been marked private.

#6

BoldMinded (Brian)

Jan 02, 2019

Run this query on your DB and paste the results here

SELECT `ct`.*, `t`.*, `d`.*, `channel_title`, `c`.`channel_name`, `c`.`channel_url`, `c`.`comment_url`, `c`.`comment_moderate`, `c`.`channel_html_formatting`, `c`.`channel_allow_img_urls`, `c`.`channel_auto_link_urls`, `c`.`comment_system_enabled`, `username`, `m`.`email`, `m`.`url`, `m`.`screen_name`, `m`.`location`, `m`.`occupation`, `m`.`interests`, `m`.`aol_im`, `m`.`yahoo_im`, `m`.`msn_im`, `m`.`icq`, `m`.`signature`, `m`.`sig_img_filename`, `m`.`sig_img_width`, `m`.`sig_img_height`, `m`.`avatar_filename`, `m`.`avatar_width`, `m`.`avatar_height`, `m`.`photo_filename`, `m`.`photo_width`, `m`.`photo_height`, `m`.`group_id`, `m`.`member_id`, `m`.`bday_d`, `m`.`bday_m`, `m`.`bday_y`, `m`.`bio`, `ct`.`url_title` AS default_url_title, `ct`.`status` AS status, `t`.`title` AS title, `t`.`site_id` AS entry_site_id
FROM (`exp_publisher_titles` AS t)
JOIN `exp_publisher_data` AS d ON `t`.`entry_id` = `d`.`entry_id` AND t.lang_id = d.lang_id AND t.status = d.status
JOIN `exp_channel_titles` AS ct ON `ct`.`entry_id` = `t`.`entry_id`
JOIN `exp_channels` AS c ON `c`.`channel_id` = `t`.`channel_id`
JOIN `exp_members` AS m ON `m`.`member_id` = `t`.`author_id`
WHERE `t`.`status` =  'open'
AND `t`.`lang_id` =  2
AND `t`.`entry_id` IN ('24363')
#7

BoldMinded (Brian)

Jan 02, 2019

Returned 1 row

"24363","1","17","4",NULL,"92.107.142.41","Top Nav Menu","top_nav_menu","open","y","0","0","0","0","y","n","1431131460","2015","05","08","0","0","1487842962","0","0","a:2:{s:12:""group_access"";s:0:"""";s:13:""member_access"";s:0:"""";}","9192","1","17","4","24363","2","open","Top Nav Menu","top_nav_menu",,"n","110","0","1431131460","20160120104705","6","9192","1","17","24363","2","open",NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,"Acerca de Lucis Trust|{path=about_us}|Acerca de Alice Bailey|{path=books/about_alice_a_bailey}|donar|{path=donate}|contacto|{path=contact_us}",NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,"* Navigation Menus","menus","{site_url}",,"n","all","y","n","y","louis@hopstudios.com","louis@hopstudios.com",,"Louis Dekeister (Hop Studios)",,,,,,,,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,"1","4",NULL,NULL,NULL,,"top_nav_menu","open","Top Nav Menu","1"
#8

BoldMinded (Brian)

Jan 02, 2019

You guys didn’t mention that it’s an issue with what appears to be with a Grid field 😊 Based on the info provided I assumed it was an issue with an entries tag query.

There is a 99.9% chance this is an issue with the Matrix to Grid importer add-on which I assume you guys used?

#9

Hop Studios

Jan 02, 2019

We did used the Matrix to Grid importer. But we did that in EE2 first and the live site (EE2) is currently using the new tags with Grid & relationship fields created by the importer. Only the selected language is displayed.
After the upgrade to EE3 is when all translations started showing up no matter what language we’re in.

#10

BoldMinded (Brian)

Jan 02, 2019

I can’t do any more relevant debugging unless I have FTP access. Can you provide that?

#11

Hop Studios

Jan 02, 2019

Comment has been marked private.

#12

BoldMinded (Brian)

Jan 02, 2019

Doesn’t seem to be working.

Can you edit the ticket and add the FTP info to the fields provided so when the ticket is closed it’s erased from the DB?

#13

BoldMinded (Brian)

Jan 02, 2019

Comment has been marked private.

#14

BoldMinded (Brian)

Jan 02, 2019

So, I’m not sure why this is the case, but if you view the list of queries on the page not 1 of them contains “grid”, so it’s doesn’t even appear to be querying the Grid field data.

#15

Hop Studios

Jan 02, 2019

Comment has been marked private.

#16

BoldMinded (Brian)

Jan 02, 2019

Something is out of whack with your setup, but I don’t know what. Neither of Publisher’s Grid or Relationship hooks are getting called. I reloaded that test page and neither die() statement was called.

#17

BoldMinded (Brian)

Jan 02, 2019

menu_navigation which was added to the template is the old Matrix field, which is why it isn’t working.

#18

BoldMinded (Brian)

Jan 02, 2019

I changed the template code and it works fine.

#19

BoldMinded (Brian)

Jan 02, 2019

While I have your attention can you share the diff on this ticket? http://boldminded.com/support/ticket/1897

#20

Hop Studios

Jan 02, 2019

So sorry for the trouble. I shortsighted the whole thing. Reason why I didn’t think about this is because the fields that are actually grid and relationship fields and tags were also duplicated (but once I replace the menu tag to the grid one, only the correct translations are returned).

Thanks for catching this. I’m going to replace the tags and see if everything works as expected.

#21

BoldMinded (Brian)

Jan 02, 2019

No worries, it happens 😊

I’ll wait to close this ticket, if I don’t hear back in a couple days I’ll assume I can close it.

#22

Hop Studios

Jan 02, 2019

Notes added.

#23

Hop Studios

Jan 04, 2019

The tags are indeed the problem. Once I update them the site is displaying correctly.

While you still have the login information, can you check for me why the default language doesn’t kick in for phrases?
https://staging.lucistrust.org/testing/check_phrases
https://staging.lucistrust.org/fr/testing/check_phrases
https://staging.lucistrust.org/ru/testing/check_phrases

It did in the EE2 version. I also checked all settings and your documentations. Would you like me to submit another ticket?

#24

BoldMinded (Brian)

Jan 05, 2019

Usually I prefer a new ticket, but since your FTP info is already in this one so lets just keep using this ticket so you don’t have to re-enter it. The CP login doesn’t appear to be working now though.

So you’re reporting that the Russian language phrases are not showing the default English translation b/c no translations have been entered in Russian? Can you share the phrase group name and a few of the phrase IDs for those in your example?

#25

Hop Studios

Jan 05, 2019
#26

BoldMinded (Brian)

Jan 06, 2019

The CP user/pass still isn’t working

#27

Hop Studios

Jan 06, 2019

The CP user/pass has been updated.

#28

BoldMinded (Brian)

Jan 07, 2019

user/pass still isn’t working for me :(

#29

Hop Studios

Jan 07, 2019

I updated the password again and changed the information attached with this ticket. Please give it another try.

#30

BoldMinded (Brian)

Jan 07, 2019

I was able to login and took a look. In this case, and I assume this is the same case for other phrases, the issue is that there is a row for the translation, but the translated value is blank, thus insinuating that it was intentionally saved with a blank value. In this case Publisher doesn’t know if the phrase is supposed to be blank, or if if it’s just missing the translation, so it can’t automatically display the default language as a fallback. You may have to go through the phrases and manually copy/paste the default values into the blank spaces and re-save the phrases :(

#31

BoldMinded (Brian)

Jan 07, 2019

The blank rows:

#32

Hop Studios

Jan 08, 2019

Hello Brian,

That seems to be the case. I tried setting the phrase_id something else and the default value kicks in. I then tried to re-save the value in the phrase edit screen, and there wasn’t a new row entered.

So I assume I can also just remove those empty rows? or do you think setting a value will be better?

#33

BoldMinded (Brian)

Jan 08, 2019

Entering a value into the blank fields and re-saving the phrases would be the best route IMO. I wouldn’t manually delete rows from the DB.

#34

Hop Studios

Jan 09, 2019

Comment has been marked private.

#35

Hop Studios

Jan 10, 2019

Comment has been marked private.

#36

Hop Studios

Jan 10, 2019

Comment has been marked private.

#37

BoldMinded (Brian)

Jan 10, 2019

The translation statuses are added to the page via an ajax load, which it does not look like it’s happening, and I suspect another add-on is using the cp_js_end hook, but not using it correctly, so Publisher’s scripts are not getting added to the page.

I’ll look into the categories when I can… could be a couple days. I need a night off of add-on work.

#38

BoldMinded (Brian)

Jan 10, 2019

I know I said it wouldn’t get to the categories today, but I took a quick look at the categories while dinner was in the oven and it was an easy fix, however, I don’t know why it is an issue for you, but for no one else.

line 445 of Controller/Manage/Categories.php

if ($group->getSiteId() !== $siteId) {

$group->getSiteId() was returning a string, not an integer value, which I have not seen before, so the conditional was failing. I changed it to the following and its working again.

if ($group->getSiteId() != $siteId) {

This is rather peculiar b/c this line has been this way for quite some time and no one else has had an issue with it.

If you have any other issues, would you mind opening a new ticket? This one has become kind of a catch all and I’d like to keep each issue separate if possible.

#39

Hop Studios

Jan 10, 2019

Sounds good. I think this one can be closed. I will create a new ticket for the category issues.

#40

BoldMinded (Brian)

Jan 10, 2019

I think the category issue is fixed, no need for another ticket for that one.

#41

Hop Studios

Jan 10, 2019

I added more notes in the new ticket. Please take a look when you have time. Thanks!
Or if you can point me the right direction, I can investigate and paste you the modifications I have to make to make my environment work.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.