EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field.
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Pagination on second language

Status Resolved
Add-on / Version Publisher 2.10.3
Severity
EE Version 4.3.6

Lincoln Gbenga Olagbaju

Nov 26, 2018

Hi,
Having some issues with pagination on the second language. On the default english language pagination works. Switching to another language the pagination links are loading on the browser address bar urls like this ‘https://www.site.com/it/temp/P12/P36/P24”
Thanks,
Lincoln

#1

BoldMinded (Brian)

Nov 26, 2018

Hi, Lincoln. This probably an issue with your template code, e.g. the base_url in your pagination tag, or the site_url or site_index being set incorrectly.

#2

BoldMinded (Brian)

Nov 26, 2018

Comment has been marked private.

#3

Lincoln Gbenga Olagbaju

Nov 26, 2018

Comment has been marked private.

#4

Lincoln Gbenga Olagbaju

Nov 26, 2018

Comment has been marked private.

#5

BoldMinded (Brian)

Nov 26, 2018

What about your template code? Have you tried to re-produce this error in a clean EE environment? I have Publisher running on a very large multi-lingual site with pagination in several areas, I’m pretty confident that this is not a bug, but something to do with the template code or site specifically. I can look into this more but I’d need a clean, brand new EE install with only Publisher installed, a single template, the most basic template code, and a few entries to paginate over.

#6

Lincoln Gbenga Olagbaju

Nov 26, 2018

Comment has been marked private.

#7

BoldMinded (Brian)

Nov 26, 2018

I have no idea what template file has your pagination tag. Can you share the template code you’re using?

#8

Lincoln Gbenga Olagbaju

Nov 26, 2018

Comment has been marked private.

#9

BoldMinded (Brian)

Nov 26, 2018

In the ee docs there is a paginate_base parameter or something similarly named to that I can’t remember off hand. Set it to {site_url}.

#10

Lincoln Gbenga Olagbaju

Nov 26, 2018

Comment has been marked private.

#11

BoldMinded (Brian)

Nov 27, 2018

You can also try paginate_base=”{current_url}”, or use the URL Helper extension and use paginate_base=”{all_segments_exclude_pagination}”

#12

Lincoln Gbenga Olagbaju

Nov 27, 2018

Hi Brian,
      using the URL Helper extension tag

paginate_base=”{all_segments_exclude_pagination} 

solved it.
Thanks.

#13

BoldMinded (Brian)

Nov 27, 2018

Just out of curiosity, something like this may work too:

paginate_base=”{path=‘press-fittings’}”

Give that a try and see if it works.

#14

Lincoln Gbenga Olagbaju

Nov 27, 2018

Brian,
    seems that is going to work and by that i mean that i can see that the pagination links urls are correct but using

[paginate_base=”{path=‘press-fittings’}”] 

is prefixing/adding the site_url to the links like this

https://www.site.com/https://www.site.com/template/P96

#15

Lincoln Gbenga Olagbaju

Nov 29, 2018

Hi Brian,
          thanks for the support, pagination issue is now solved.
Consider this ticket closed.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.