Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: total_rows and is_last_row variables do not work correctly

Status Resolved
Add-on / Version Simple Grids & Tables 4.0.8
Severity
EE Version 4.3.1

Nick Johnson

Oct 09, 2018

Description:

The total_rows variable only outputs 1 for each row, and is_last_row outputs 1 only for the first row and not the last. This is currently occurring inside of a Bloq field.

Detailed steps to reproduce the issue:
1. Create a Bloq with 2 fields: simple text field and a Simple Grid field (contains 2 columns, both text areas)
2. On output, all 5 rows in the Simple Grid field are output correctly, with the “count”, “row_id”, and “is_first_row” variables all outputting the correct values.
3. For all 5 rows, “total_rows” only ever outputs 1 (when it should be 5).
4. “is_last_row” outputs 1 for the first row only, and is empty for all remaining rows (when it should be empty for all rows but the last, when it should be 1)

#1

BoldMinded (Brian)

Oct 09, 2018

Comment has been marked private.

#2

Nick Johnson

Oct 09, 2018

Thanks Brian,

For my purposes, “total_rows” now correctly outputs 5 so this works for me. However, I did notice that “is_last_row” still outputs “1” on the first row and not the last.

#3

BoldMinded (Brian)

Oct 09, 2018

Comment has been marked private.

#4

Nick Johnson

Oct 10, 2018

Perfect, thanks!

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.