Be sure to checkout our newest add-on, Speedy — Advanced Caching for ExpressionEngine.

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: 4.0.7 introduced a new bug

Status Resolved
Add-on / Version Bloqs 4.0.7
Severity
EE Version 4.3.6

Dan Munday

Oct 06, 2018

Description:
after it is updated to 4.0.7 I notice there is a weird behaviour when adding new atoms.

Observations:
1. If the block is not nestable this behaviour does not exist.
2. If the block is nestable, after adding more than one atom and hit “save” afterwards, the first instance will be gone.
3. This behaviour only happens once if there is at least one atom under the block.
4. However, if you remove all the atoms and hit save and start over, the behaviour will happen again

Detailed steps to reproduce the issue:
1. go to the entry and add a new atom (e.g. a new paragraph)
2. add another atom (heading 2)
3. hit save
4. the first atom (paragraph) will be gone.
5. add back the paragraph and hit save. it works fine.
6. remove all the atoms
7. start over and create two atoms and hit save
8. the first one will be gone.

 

#1

BoldMinded (Brian)

Oct 06, 2018

This doesn’t sound like anything the changes from 4.0.6 to 4.0.7 would have done. If you downgrade to 4.0.6 does this not happen?

#2

BoldMinded (Brian)

Oct 06, 2018

Also, when you say “add another atom” are you referring to the block editing process b/c you can’t add an atom when you’re editing an entry, only when creating a block. If you’re editing an entry you’d be adding a block that contains atoms. Just seeking clarification here… screenshots or a quick video would help if you can provide it.

#3

BoldMinded (Brian)

Oct 06, 2018

You said this happened after upgrading to 4.0.7… what version were you on before upgrading?

#4

Dan Munday

Oct 06, 2018

4.0.6

when I say adding another atom, I mean in the entry itself I create contents by adding another atom, e.g. adding a quote of Shapespear; I do not mean to create a block under the Bloqs preference.

#5

Dan Munday

Oct 06, 2018

no problem under 4.0.6
under 4.0.7 I created two identical blocks with the exact same atoms with the same order.
Once is set to nestable while another one is not.

Again, following the steps that I described, the one that is nestable will remove the first atom after I hit save.

#6

Dan Munday

Oct 06, 2018

the testing site is with 4.0.6 and no problem at all.
http://harthous.nextmp.net

My local dev is with 4.0.7 (I notice there is something new under 4.0.7, there is a message, “No blocks found. Add your first block from the options below.” when there is not atom added. I am not sure if this is the reason why this issue happened.)

#7

BoldMinded (Brian)

Oct 06, 2018

Are you able to provide a video of this happening so I can clearly see what you are seeing?

#8

Dan Munday

Oct 06, 2018

okay

#10

BoldMinded (Brian)

Oct 06, 2018

Do you have Publisher installed on this site?

#11

Dan Munday

Oct 06, 2018

no

#12

Dan Munday

Oct 06, 2018

it only has bloqs and simple grid installed

#13

BoldMinded (Brian)

Oct 06, 2018

Comment has been marked private.

#14

Dan Munday

Oct 06, 2018

thank you so much. Brain.
it works

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.