Be sure to checkout our newest add-on, Speedy — Advanced Caching for ExpressionEngine.

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: All the bloqs atoms cannot be searched using EE native simple search form

Status Resolved
Add-on / Version Bloqs 4.0.6
Severity
EE Version 4.3.5

Dan Munday

Oct 02, 2018

Description:
All the bloqs atoms cannot be searched using EE native simple search form. I am not sure if I have missed anything.


Detailed steps to reproduce the issue:
1. I created a Bloqs field, named “Blog Blocks” and make in “Include in Search” where an atom, textarea, is also “Include in Search”
2. Create a new blog entry
3. go to the Bloqs field and type some words, in my case, “Chizoba”
4. Go to simple search form and type “Chizoba” and no results returned.

p.s. I use the default EE default template

 

#1

Dan Munday

Oct 02, 2018
<section class="row pad">
   <section class="w-12">
    {layout:contents}
   </section>
   <section class="w-4">
    <div class="sidebar">
     {exp:search:simple_form
      form_class='search'
      channel='{layout:ch}'
      search_in='everywhere'
      where='all'
      result_page='{layout:p_url}/search'
      no_result_page='{layout:p_url}/no-results'
      results='5'
     }
      <input type="text" name="keywords" id="keywords" value="" placeholder="Type keywords, hit enter">
     {/exp:search:simple_form}
     <h2>Categories</h2>
     <ul class="list yes">
      {exp:channel:categories channel='{layout:ch}' style='linear'}
       <li><a href="http://{path={layout:p_url}/{p_url_cat}/{category_url_title}}">{category_name}</a></li>
      {/exp:channel:categories}
     </ul>
     <h2>RSS Feed</h2>
     <ul class="list rss">
      <li><a href="http://{path={layout:p_url}/rss}">Subscribe to {layout:p_title}</a></li>
     </ul>
    </div>

   </section>
  </section>
#2

BoldMinded (Brian)

Oct 02, 2018

Do you have Publisher or any other add-ons installed? Go to the PublishController.php file and find this on line 634. Add a die(‘testing’); inside of the conditional to see if its triggering, if not, it means you fields and atoms themselves are not set to searchable.

if (count($searchValues) > 0) {
die('testing');
            $this->_adapter->updateFieldData($entryId, $this->_fieldId, encode_multi_field($searchValues));
        }
#3

Dan Munday

Oct 03, 2018

I don’t have the Publisher installed. A fresh new EE install with only Bloqs and “Simple Grid and tables”
I did set them searchable.
Please help

#4

BoldMinded (Brian)

Oct 03, 2018

Did you add the die() statement? To provide more info you could change it to var_dump($searchValues); die();

#5

Dan Munday

Oct 03, 2018

please let me know where i can add the die statement. Where can i find the PublishController.php? many thanks

#6

BoldMinded (Brian)

Oct 03, 2018

I tested locally and it appears that it saves correctly every other time, which is odd. I’ll look into this but due to my schedule right now it could be a few days before I have it fixed.

#7

Dan Munday

Oct 03, 2018

I just add that line.

and i do a search and it stills returns a zero result

#8

Dan Munday

Oct 03, 2018

hey Brian,
so what does it mean? is it a bug or is it only on my side?

#9

Dan Munday

Oct 03, 2018

since our university site is heavily replied on Bloqs, hope that the issue will be solved soon.

here is our testing site. http://harthous.nextmp.net/blog
for our blog entry only the title and blurb are native ee field all the major contents are on Bloqs field.
Try typing “Chizoba” and it returns nothing.
thanks

#10

BoldMinded (Brian)

Oct 03, 2018

I’ll do what I can to get it fixed in a timely manor, but I have a lot going on right now.

#11

Dan Munday

Oct 03, 2018

please as this one is kind of urgent. Many thanks

#12

BoldMinded (Brian)

Oct 03, 2018

Comment has been marked private.

#13

Dan Munday

Oct 03, 2018

Hi Brain,
Something might get your attention.
If i assign that entry to a category, it can be searchable.
If i assign that entry no category at all. it CANNOT be searchable
If I assign that entry to more than one category group (in this case, Blog type and Global category), it CANNOT be searchable.

Hope this information help

#14

BoldMinded (Brian)

Oct 03, 2018

I don’t think it has anything to do with categories. I can see in the code where it is blanking out a database table column that is used for searching. If you save the entry multiple times, on every other save, it will be searchable, then the next save, it won’t be searchable. I think that is what you’re encountering when saving the categories.

#15

Dan Munday

Oct 03, 2018

ah i see

#16

BoldMinded (Brian)

Oct 03, 2018

Comment has been marked private.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.