Be sure to checkout our newest add-on Reading Time Pro!

Compatibility updates:

  • Publisher is EE5 compatible, but it does not currently support the Fluid field (it's in the works).

Ticket: Warning message pops up when adding a new bloq item which has a simple grid atom

Status Resolved
Add-on / Version Simple Grids & Tables 1.02
Severity
EE Version 4.3.1

Dan Munday

Sep 19, 2018

Description:
A warning message pops up when adding a new Bloqs item which has a simple grid atom

Detailed steps to reproduce the issue:
1. Go to Bloqs
2. Create a new Bloqs item named “Ticket List”
3. the first atom is Heading (text input)
4. the second atom is “ticket” (simple grid) in which the first row is “group” while the second is “price”
5. Go to the custom field, Block, and I add the new “Ticket List” Bloqs item
6. In my case, create a new blog entry
7. add a new Bloqs item (Ticket List) and leave it empty (see the screenshot)
8. click save
9. Warning message appears:

Warning

Invalid argument supplied for foreach()

user/addons/simple_grids/ft.simple_grid.php, line 58

Severity: E_WARNING
Warning

Cannot modify header information - headers already sent by (output started at ee/legacy/core/Exceptions.php:119)

ee/legacy/core/Input.php, line 237

Severity: E_WARNING
Warning

Cannot modify header information - headers already sent by (output started at ee/legacy/core/Exceptions.php:119)

ee/legacy/core/Input.php, line 237

Severity: E_WARNING
Warning

Cannot modify header information - headers already sent by (output started at ee/legacy/core/Exceptions.php:119)

ee/legacy/libraries/Functions.php, line 392

Severity: E_WARNING

#1

BoldMinded (Brian)

Sep 19, 2018

Comment has been marked private.

#2

Dan Munday

Sep 20, 2018

Still has the same warning message

#3

BoldMinded (Brian)

Sep 20, 2018

Did you just upload the new files? If so that won’t fix it. You may have to re-save the entry.

#4

Dan Munday

Sep 20, 2018

when I click save and closed the warning message appears again. this is a brand new install only with Bloqs and simple grids

#5

BoldMinded (Brian)

Sep 20, 2018

Can you provide CP info so I can login and take a look at the config? Just tell me what the name of the field is, and which channel name and entry id I can test it in.

#6

Dan Munday

Sep 20, 2018

And even worse, after i installed the revised version the simple grids does not appear at all.

Chris

#7

Dan Munday

Sep 20, 2018

This is a local install specifically for testing add-ons.

#8

Dan Munday

Sep 20, 2018

It works fine when it is a stand-alone simple grid field

#9

Dan Munday

Sep 20, 2018

Simple grid inside Bloqs does not allow me to use the options button located at the right top corner either.

#10

Dan Munday

Sep 20, 2018

After I installed the original version of Simple Grid it is back to normal now except the original issue that I reported.

#11

BoldMinded (Brian)

Sep 20, 2018

Comment has been marked private.

#12

Dan Munday

Sep 20, 2018

this time, the simple grid can display in the block and the option button works again. However, when I do not add any row the warning message still pops up.

#13

Dan Munday

Sep 20, 2018

If I add a row and leave it empty, hitting “Save” does not return any error message.

#14

BoldMinded (Brian)

Sep 20, 2018

Ok, I missed #7 in your original ticket, which explains why it works for me b/c I’m entering data.

#15

BoldMinded (Brian)

Sep 20, 2018

Actually, I just added 3 blocks each with an empty Simple Grid field and they saved fine with no errors, or errors on page reload.

#16

Dan Munday

Sep 20, 2018

I am sorry that I did not communicate the issue clearly in my original post. My concern is that if my colleague adds a new block element and leave it empty and then click save, they will be freaked out when a warning message displays.

#17

Dan Munday

Sep 20, 2018

as i said before, adding an empty row has no issue at all. No row will return an error message

#18

Dan Munday

Sep 20, 2018

Interesting. Let me figure it out again. thanks so much

#19

BoldMinded (Brian)

Sep 20, 2018

here is a video of me saving in several variations. https://d.pr/i/eU4JdN

#20

Dan Munday

Sep 20, 2018

really appreciated. I just found out it works on my production site but my local add-on testing site still has errors. Wierd

#21

Dan Munday

Sep 20, 2018

Hey Brian,
so any possible reason for that warning message in my local dev?
Thanks

#22

BoldMinded (Brian)

Sep 20, 2018

Check php version, make sure 100% that the files you think are loading (eg no symlink pointing elsewhere you forgot about). Try uninstalling reinstalling (not sure how that would fix it but can be usual part of debugging).

#23

Dan Munday

Sep 20, 2018

The only difference is that the local dev is 7.1.12 while the production server is 7.0.30; i am not sure if this would make the difference on this particular issue. Anyway thank you

#24

BoldMinded (Brian)

Sep 21, 2018

No, those php versions wouldn’t make a difference. This happens on every entry and every block? Or its just happening in 1 entry?

#25

Dan Munday

Sep 21, 2018

Yes. on every entry and the block where it has an atom of a Simple Grid field. I will send you a video. Thanks

#26

BoldMinded (Brian)

Oct 06, 2018

Dan, you haven’t sent a video of this or followed up… is this still an issue? If so the video would help, otherwise if I don’t hear anything in a couple days I’ll assume this isn’t an issue anymore and close the ticket.

#27

Dan Munday

Oct 06, 2018

Hi Brain,
I will send it over; just very swamped recently.
By the way, this is Chris here and Dan is my manager.
Chris

#29

BoldMinded (Brian)

Oct 06, 2018

Comment has been marked private.

#30

Dan Munday

Oct 06, 2018

hi Brian,
I guess you changed the behaviour of this field type. Right now it won’t return the PHP warning messages anymore, but it does show a red error message, “There was an error in one or more blocks” if the simple grid has no row at all. Once I add a row I can save the entry. It behaves differently than the native grid fieldtype (it won’t return errors if no rows are added) If this is what you intended, I can live with it. Many thanks.

#31

Dan Munday

Oct 06, 2018

Hi Brian,
please ignore the previous message; i did not test it thoroughly.
It still returns the php error message unless I make this field required.
Chris

#32

BoldMinded (Brian)

Oct 07, 2018

I feel like something is wrong with your environment b/c I wasn’t able to replicate this when you initially reported the ticket and still can’t replicate it. Based on the error message though I added an additional check that should prevent the error (though it shouldn’t be needed).

#33

BoldMinded (Brian)

Oct 07, 2018

Comment has been marked private.

#34

Dan Munday

Oct 07, 2018

Hi Brian,
I think you may simply ignore it. I agree with you that the issue might be related to my env only.
So you may close the ticket and I really appreciate your help.
Chris

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.