EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field.
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Diff causing 500 internal error

Status Resolved
Add-on / Version Publisher Lite 2.8.3
Severity
EE Version 4.3.3

Sears Davies

Sep 17, 2018

Description:
- - -
Enabling Diff on the control panel results in a 500 internal server error when you try to view the draft version of an entry.

Detailed steps to reproduce the issue:
- - -
1. Install Publisher Lite on a website with existing content
2. Edit an entry and save a draft
3. Enable Diff (Full or Text Only)
4. Set the default view state to Open
5. Open the entry you edited in 2.
6. Change the view dropdown to View (Draft)

#1

BoldMinded (Brian)

Sep 17, 2018

Hi, Sears. Did you check the PHP error logs to see what error is being thrown? I need something to go off of to fix or debug this. If its something caused by your content, then I will have no way to replicate it or know what the cause is without an error message.

#2

Sears Davies

Sep 17, 2018

These are the errors reported in the errors log:

[warn] [client xxx.xxx.xxx.xxx] mod_fcgid: read data timeout in 45 seconds, referer: https://www.mydomainhere.com/admin.php?/cp/publish/edit/entry/501
[error] [client xxx.xxx.xxx.xxx] Premature end of script headers: admin.php, referer: https://www.mydomainherers.com/admin.php?/cp/publish/edit/entry/501

#3

BoldMinded (Brian)

Sep 17, 2018

What is the full content you’re trying to diff? Did you try to increase your memory limit or execution time? Diffing a large amount of content may be running into those limits.

#4

BoldMinded (Brian)

Nov 13, 2018

Closing this ticket b/c its been almost 2 months with no response.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.