EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field.
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Relationships inside of Bloqs do not display in Live Preview

Status Resolved
Add-on / Version Publisher 2.8.3
Severity
EE Version 4.3.3

Martyn Tan

Aug 07, 2018

Hi,

I’ve created accounts for editors and publishers. When I logged into a publisher account to approve and preview entries, the preview isn’t showing when I approved it.  There isn’t any javascript console errors. Below is a video link highlighting the issue.

https://youtu.be/aoHDAO84qzs

Detailed steps to reproduce the issue:
1. In an entry to be approved, click “Approve and Preview”
2. Preview window doesn’t show.

 

#1

BoldMinded (Brian)

Aug 07, 2018

You need to change the dropdown to save as Draft in order for the preview to display.

#2

BoldMinded (Brian)

Aug 07, 2018

I think the bug here is that the save and preview button says the wrong text when the page loads. It shouldn’t say that until you change the save as status to Draft.

#3

Martyn Tan

Aug 07, 2018

I’ve come up with a video on the route a publisher need to take to preview the draft and approve it. Please help to check if the workflow is correct.

https://www.youtube.com/watch?v=Z_2qMGwWv2I

1) Navigate to View Draft
2) Choose either preview or “save and preview”
3) After confirming content is in order,  navigate back to View Draft
4) Ensure the top left selected dropdowns are “View Draft”  and “Save As Published” .
5) Click Approve Draft and Preview / Approve Draft and Close

Will the button “Approve draft & Preview” be removed in future as it currently doesn’t allow any preview?

#4

BoldMinded (Brian)

Aug 07, 2018

The button text is just incorrect. If you change the Save As dropdown to Draft then you should see the preview.

#5

Martyn Tan

Aug 14, 2018

Hi,

Many thanks for the correction. The preview is getting me confused due to a couple of bugs.

It seems like Relationship fields in a bloq field can’t be previewed (with the blue preview button). It can be view on the frontend normally though.

To reproduce it
1. Create a bloq type that has relationship with another channel
2. Add the bloq type to a channel entry and save it
3. Click the blue preview button and bloq relationships isn’t rendered in the split preview screen.

Bug no.2 is updates to bloq relationship field can’t be saved when there is another channel field referencing the same other channel for relationships. I’ve uploaded a video showcasing both the bugs.
https://youtu.be/WyZJ8lb2X14

Video is taken with a fresh installation of EE4.3.3 and Bloqs 4.0.5.  I’ve updated the ticket for the CMS EE login too.

#6

BoldMinded (Brian)

Aug 14, 2018

Thanks, I’ll take a look at that this week.

#7

BoldMinded (Brian)

Aug 14, 2018

I’ve gotten the button text issue fixed for the next release, and I’m unable to replicate the Bloqs > Relationship issue you’re describing. I’ve tested it in two different environments. Have you tried setting up a clean EE install with just Bloqs installed to see if you can replicate it? What other add-ons do you have installed?

#8

BoldMinded (Brian)

Aug 14, 2018

I logged into your environment and I see it happening, but it only happens if there is another Relationship field on the page below the Bloqs field. I feel like this has happened before, but I resolved it. I’ll take another look… it could be a few days before I can dig into it though.

#9

BoldMinded (Brian)

Aug 14, 2018

I have a feeling this is a newly introduced bug from EE. I removed the standalone Relationship field, saved a Relationship field that was inside of Bloqs, and it saves and displays the selected relationships just fine. Then I added the standalone field back to the main channel and without saving anything, it displays the selected relationships from the Relationship field inside of Bloqs.

#10

BoldMinded (Brian)

Aug 16, 2018

I can’t replicate this locally. If you’re still seeing this happen, try un-installing and re-installing Publisher and Bloqs, but before you do that, make a backup of your exp_extensions table, then make another backup afterward so I can compare the two (paste the results here or put the .sql dump files somewhere I can get them.

#11

BoldMinded (Brian)

Aug 16, 2018

Comment has been marked private.

#12

Martyn Tan

Aug 16, 2018

Here’s the link to the mysql dump of exp_extensions table

https://drive.google.com/drive/folders/1iuL94anRE3dmaX0zZ_u6GPPKJxXbyr0N?usp=sharing

————————————————————————————

With the 2.8.4 patch I’m able to save the relationships in bloq now even with the standalone relationship field.  However I’m still unable to view the bloq relationships in the preview window (the blue preview button, not the save and preview button). Save draft and preview is working correctly.

 

 

#13

BoldMinded (Brian)

Aug 16, 2018

Thanks. I’ll take a look at the live preview stuff next week.

#14

Martyn Tan

Aug 22, 2018

Hi Brian,

Is there any updates on the live preview for bloq relationships?

#15

BoldMinded (Brian)

Aug 23, 2018

Nope, haven’t had a chance to look into it yet. Since it’s not a data loss issue or something affecting the front-end of the site display its slightly lower priority right now.

#16

BoldMinded (Brian)

Aug 23, 2018

Martyn, I can replicate the issue, but unsure how to fix it. 95% of the code behind this is native EE stuff, so I’m not sure if its a Bloqs issue or EE issue at this point. I’ll look into it more over the next few days. I don’t know when I’ll have a fix.

#17

BoldMinded (Brian)

Aug 27, 2018

Martyn, after looking into this a bit I’m afraid that I’m not going to have a fix anytime soon. Its an issue with how EE internally displays Relationships when inside of Grid. Even though Bloqs is basically a glorified Grid field, internally EE does not recognize Bloqs, so they need to either change something, or give me a new hook to work with. It’ll take some time working with EllisLab to get a fix in place. Sorry for the bad news.

#18

BoldMinded (Brian)

Aug 27, 2018

Comment has been marked private.

#19

BoldMinded (Brian)

Sep 06, 2018

Martyn I got approval from EllisLab to add a new hook, but it could be a few weeks before I get it implemented. This will be resolved, but unfortunately its going to take some time.

#20

Martyn Tan

Sep 12, 2018

Many thanks for the help, really appreciate it.

#21

BoldMinded (Brian)

Nov 17, 2018

I’m going to try to look into this again soon, but last time I was working on this it appeared as if I was doing everything correctly, but the relationships still did not show up in the preview.

#22

BoldMinded (Brian)

Nov 22, 2018

I think I have a fix for this… I’ll try to get it released after the Thanksgiving holiday.

#23

BoldMinded (Brian)

Nov 23, 2018

Closing this out, the fix will be in the 4.0.12 release next week.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.