Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: Multiple Layouts using same template?

Status Resolved
Add-on / Version
Severity Trivial
EE Version

Michael Olson

Aug 16, 2012

I would like to have multiple publish layouts, but which use the same template. Is this possible?

For example (see screenshot), a publish layout called “3-Step Process” would include this custom field in the publish entry screen for the user. On the other hand, if a publish layout called “Default” is selected it would NOT show this custom field for the user.

Both layouts would use the same template (for example, “main/pages”), but there would simply be a conditional in the template for that specific field to output or not - {if 3step != ""}{3step}{/if}

The reason for this is to remove certain fields from the publish screen when they aren’t necessary. Everything else in the page template is the same, so it makes more sense to only conditionally output those optional fields in the template when they are actually being used, and not create entirely new templates just for when they are…

Am I understanding Blueprints right in that it can accommodate this? Or does every publish layout REQUIRE a unique template to be assigned?

#1

BoldMinded (Brian)

Aug 16, 2012

Well, I think it was intended to have a 1 to on1 relationship, but now that I think about it there shouldn’t be anything to prevent it otherwise. Have you tried this, but it isn’t working?

#2

Michael Olson

Aug 17, 2012

Yeah I tried it - you can see in the screenshot I attached that it is only showing the one thumbnail and not both.

#3

Michael Olson

Aug 21, 2012

Any new thoughts on this?

#4

BoldMinded (Brian)

Aug 27, 2012

Can you email me a CP login so I can take a closer look? litzinger at gmail dot com. Thanks

#5

P H

Sep 04, 2012

I could use this feature as well.

I have 3 layouts associated with 1 template but only one of the layouts appear in the Template Carousel or drop down.  And that is the first layout that was assigned to that template.

#6

BoldMinded (Brian)

Sep 09, 2012

I don’t think this is something I want to change Blueprints to do. Even if I could, it would be very complicated, how would I determine which layout to load based on the template ID? For instance, if layouts A and B were both attached to template 1, the publish page loads and sees that the current template is 1, then it looks to see which layout is attached to that template. If there are two, how does it know which one to pick?

Login to reply