Be sure to checkout our newest add-on Reading Time Pro!

EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: Entries with multiple bloqs fieldtypes get blocked after multiple bloqs elements are added

Status Resolved
Add-on / Version Bloqs 4.0.3
Severity
EE Version 4.3.1

Josh Noble

Jun 23, 2018


Description:

When there are multiple bloqs fieldtypes in the same channel, after adding enough elements in some of them (this number seems to depend on other factors) the entry gets blocked by a date validation error saying the publication date field is empty while being mandatory. This is wrong as the field is visibly holding it’s usual value. The error blocks any subsequent update of the entry and in addition it affects the entry status field in the “Options” tabs removing the selected choice (none of the radio buttons there looks selected even though it is). On page refresh everything looks fine but any attempt to re-save the entry results in the error popping up.

Manually deleting some of the created bloqs elements for that entry from “blocks_block” in the database seems to “free up” some space, unlocking it for changes. In some cases this even allows the addition of more elements than the amount of the removed ones but eventually the entry locks up again. This cycle can be repeated to gradually get more content in but obviously this isn’t a solution.

It also seems that having bloqs fieldtype with bigger selection of types are triggering the issue earlier - fewer complex fields with less data seem to cause the error earlier than more, simpler fields with more data. For example in the attached images 60+ elements were needed to trigger the error but in entries with more complex fields 18-20 elements were enough.

In some cases different notices and warning pop up - these can be seen in the attached images. In that particular case the elements that are seen at the bottom were actually children of 2 other levels before them - these parents disappeared, the children moved to root level on that field and all these notices displayed before them.

 

 

#1

BoldMinded (Brian)

Jun 23, 2018

I just had to read the first paragraph to know what the problem is. Increase your max_post_vars in your php config. Basically you’re posting so many fields which is beyond your config limit so EE is not seeing the date field bc it is truncated from the POST array, then throws the error.

#2

Josh Noble

Jun 25, 2018

That seems to be it as icreasing the related settings solves the issue. I’ll keep an eye on it and let you know if it happens again and additional increase doesn’t work. Thank you!

#3

BoldMinded (Brian)

Jun 25, 2018

You’re welcome. I don’t know what you increased the settings to, but I think I’ve taken it all the way up to 10,000 before with no side effects.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.