EE4 compatibility updates:

  • Publisher is EE4 and EE5 compatible, but it does not currently support the Fluid field (it's in the works).
  • Reel is EE4 and EE5 compatible, but it does not currently support the Fluid field.

Ticket: fluid grid fields automatically multiplying

Status Resolved
Add-on / Version Publisher 2.8.2
Severity
EE Version 4.3.1

Matthias Ballmann

Jun 12, 2018

dear brian,

we have a strange phenomenon with a fluid-grid field that consists of three text fields into which you have to enter parts of a URL to integrate an audio embed into the page. As soon as you did this and the entry was saved, one grid entry suddenly became two – even if “1” was entered as minimum and maximum. As soon as I save the entry one more time, there are four entries in the grid… and so on.

yesterday I wrote a ticket to expressionengine and robin answered after logging:

“I’ve been looking at this one- I’ve been doing a good bit of testing and the most simplified thing I’ve done is create a test2 channel with a ‘test’ fluid field in it. The only field in the fluid field is ‘audio’. I get the ‘double’ effect if I post to it.
Weirdly, I can’t replicate locally. I set up an identical test channel and ‘test’ fluid field with a grid field like the one on your site. No doubling.
Note- this only happens when the grid is in a fluid field- just the audio field by itself seemed fine.
I think it’s due to an addon, and looking at the exp_channel_grid_field_38 I suspect it’s publisher. One row has ‘open’ one has ‘draft’.
You’re going to need to ping the Publisher team on this one. Let’s see what they suggest.
For now, I’d leave the ‘test’ channels and fields and delete them once the issue is cleared up. They make it considerably easier to debug.”

you can see the behaviour with the entry id 1484 “Women Between Buildings” for instance.


thank you
and kind regards,
matthias

#1

BoldMinded (Brian)

Jun 12, 2018

Publisher does not work with the Fluid field yet, and may not for some time.

#2

Matthias Ballmann

Jun 12, 2018

so these doubling of the fluid grid fields is in no way related to publisher?

#3

BoldMinded (Brian)

Jun 12, 2018

It may be Publisher that is doing it b/c it doesn’t know how to handle Fluid fields. You can try to set Fluid fields to be ignored and see if that changes its behavior.

#4

BoldMinded (Brian)

Jun 28, 2018

Matthias, I haven’t heard anything in a couple of weeks, so I’m going to close this ticket.

Login to reply

Contact

For add-on support, please use the Support section. General inquries and pre-sale questions can be sent to support@boldminded.com.