Publisher is EE6 compatible, but it does not support the Fluid field. Please do not contact asking when support will be available.

If you purchased an add-on from expressionengine.com, be sure to visit boldminded.com/claim to add the license to your account here on boldminded.com.

Ticket: PHP error in fieldtype setting since 1.4.1 upgrade from 1.3.4

Status Resolved
Add-on / Version
Severity Trivial
EE Version 16

Colin Kirsopp

May 09, 2012

Hi,

Sorry to be a bother, but…

I was going to try changing the fieldtype settings paths and I’ve just noticed that I get the following PHP error when trying to view the field type settings.

A PHP Error was encountered
Severity: Warning
Message: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wyvern_ft’ does not have a method ‘display_global_settings’
Filename: api/Api_channel_fields.php
Line Number: 350

It’s the first time I’ve looked at this since upgrading from 1.3.4 to 1.4.1 - so may be upgrade related.

Thanks,
Colin

#1

Colin Kirsopp

May 09, 2012

Don’t worry.  I upgraded my EE to 2.5 and this issue disappeared.

#2

Brian Litzinger

May 10, 2012

I need a better way to handle this, but yeah you might see that message b/c I moved the settings to the module page. You only see that if you were on the settings page, did the upgrade, and tried reloading the settings page which doesn’t exist in that location anymore. Glad you figured it out though, will sort this out in the next release.

Login to reply